aboutsummaryrefslogtreecommitdiff
path: root/libraries/restbed/restbed.patch
diff options
context:
space:
mode:
Diffstat (limited to 'libraries/restbed/restbed.patch')
-rw-r--r--libraries/restbed/restbed.patch12
1 files changed, 12 insertions, 0 deletions
diff --git a/libraries/restbed/restbed.patch b/libraries/restbed/restbed.patch
new file mode 100644
index 0000000000000..52fdbe58d09af
--- /dev/null
+++ b/libraries/restbed/restbed.patch
@@ -0,0 +1,12 @@
+Only in restbed-4.0: .CMakeLists.txt.un~
+diff -ur restbed-4.0.old/CMakeLists.txt restbed-4.0/CMakeLists.txt
+--- restbed-4.0.old/CMakeLists.txt 2016-04-14 18:38:26.000000000 -0300
++++ restbed-4.0/CMakeLists.txt 2017-01-03 18:15:29.883784733 -0200
+@@ -71,5 +71,5 @@
+ install( FILES "${INCLUDE_DIR}/${PROJECT_NAME}" DESTINATION "include" )
+ install( FILES ${BUILD_ARTIFACTS} DESTINATION "include/corvusoft/${PROJECT_NAME}" )
+ install( TARGETS ${PROJECT_NAME}
+- LIBRARY DESTINATION "library"
+- ARCHIVE DESTINATION "library" COMPONENT library )
++ LIBRARY DESTINATION "lib${LIB_SUFFIX}"
++ ARCHIVE DESTINATION "lib${LIB_SUFFIX}" COMPONENT library )