aboutsummaryrefslogtreecommitdiff
path: root/libraries/redland/redland.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'libraries/redland/redland.SlackBuild')
-rw-r--r--libraries/redland/redland.SlackBuild16
1 files changed, 12 insertions, 4 deletions
diff --git a/libraries/redland/redland.SlackBuild b/libraries/redland/redland.SlackBuild
index 21c92a4f225d..c409ef1631a0 100644
--- a/libraries/redland/redland.SlackBuild
+++ b/libraries/redland/redland.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for redland
-# Copyright 2007-2008 Heinz Wiesinger <hmwiesinger@gmx.at>
+# Copyright 2007-2009 Heinz Wiesinger <pprkut@liwjatan.at>
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -23,9 +23,9 @@
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
PRGNAM=redland
-VERSION=1.0.8
+VERSION=1.0.9
ARCH=${ARCH:-i486}
-BUILD=${BUILD:-1}
+BUILD=${BUILD:-2}
TAG=${TAG:-_SBo}
CWD=$(pwd)
@@ -52,6 +52,13 @@ cd $PRGNAM-$VERSION
chown -R root:root .
chmod -R u+w,go+r-w,a-s .
+# Fix loading of modular storage engine from external applications
+# like SVN revision 15171
+for i in MYSQL POSTGRESQL SQLITE TSTORE; do
+ sed -i "s/LIBADD = @${i}_LIBS@/LIBADD = @${i}_LIBS@ librdf.la/" \
+ src/Makefile.in
+done
+
CFLAGS="$SLKCFLAGS" \
CXXFLAGS="$SLKCFLAGS" \
./configure \
@@ -60,7 +67,8 @@ CXXFLAGS="$SLKCFLAGS" \
--localstatedir=/var \
--mandir=/usr/man \
--disable-static \
- --with-threads
+ --with-threads \
+ --build=$ARCH-slackware-linux
make
make install-strip DESTDIR=$PKG