aboutsummaryrefslogtreecommitdiff
path: root/libraries/python-efl/python-efl.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'libraries/python-efl/python-efl.SlackBuild')
-rw-r--r--libraries/python-efl/python-efl.SlackBuild6
1 files changed, 3 insertions, 3 deletions
diff --git a/libraries/python-efl/python-efl.SlackBuild b/libraries/python-efl/python-efl.SlackBuild
index 064da6baeb298..562e266392fa7 100644
--- a/libraries/python-efl/python-efl.SlackBuild
+++ b/libraries/python-efl/python-efl.SlackBuild
@@ -1,7 +1,7 @@
#!/bin/bash
# Slackware build script for python-efl
-# Erik Falor | Logan, UT, USA | ewfalor@gmail.com | July 2020
+# Erik Falor | Logan, UT, USA | ewfalor@gmail.com | February 2022
# This program is free software: you can redistribute it and/or modify
# it under the terms of the GNU General Public License as published by
@@ -24,7 +24,7 @@
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=python-efl
-VERSION=${VERSION:-1.24.0}
+VERSION=${VERSION:-1.25.0}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -80,7 +80,7 @@ find -L . \
CFLAGS="$SLKCFLAGS" \
CXXFLAGS="$SLKCFLAGS" \
-python setup.py install --root=$PKG
+python3 setup.py install --root=$PKG
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true