aboutsummaryrefslogtreecommitdiff
path: root/libraries/pyPEG2/pyPEG2.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'libraries/pyPEG2/pyPEG2.SlackBuild')
-rw-r--r--libraries/pyPEG2/pyPEG2.SlackBuild9
1 files changed, 8 insertions, 1 deletions
diff --git a/libraries/pyPEG2/pyPEG2.SlackBuild b/libraries/pyPEG2/pyPEG2.SlackBuild
index 1b9ed36ae6d6b..669bcfbf82ac6 100644
--- a/libraries/pyPEG2/pyPEG2.SlackBuild
+++ b/libraries/pyPEG2/pyPEG2.SlackBuild
@@ -24,7 +24,7 @@
PRGNAM=pyPEG2
VERSION=${VERSION:-2.15.2}
-BUILD=${BUILD:-2}
+BUILD=${BUILD:-3}
TAG=${TAG:-_SBo}
if [ -z "$ARCH" ]; then
@@ -69,8 +69,15 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+python setup.py build
python setup.py install --root=$PKG
+# Build mutagen with python3. Default is no.
+if [ "${PYTHON3:-no}" == "yes" ]; then
+ python3 setup.py build
+ python3 setup.py install --root=$PKG
+fi
+
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true