aboutsummaryrefslogtreecommitdiff
path: root/libraries/lgi
diff options
context:
space:
mode:
Diffstat (limited to 'libraries/lgi')
-rw-r--r--libraries/lgi/lgi.SlackBuild18
-rw-r--r--libraries/lgi/lgi.info2
2 files changed, 9 insertions, 11 deletions
diff --git a/libraries/lgi/lgi.SlackBuild b/libraries/lgi/lgi.SlackBuild
index 7077cf00d5b8..47f5c5e5c502 100644
--- a/libraries/lgi/lgi.SlackBuild
+++ b/libraries/lgi/lgi.SlackBuild
@@ -24,11 +24,13 @@
# Modified by the SlackBuilds.org project
+# 20241018 bkw: BUILD=2, build with lua51.
+
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=lgi
VERSION=${VERSION:-0.9.2}
-BUILD=${BUILD:-1}
+BUILD=${BUILD:-2}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -40,9 +42,6 @@ if [ -z "$ARCH" ]; then
esac
fi
-# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
-# the name of the created package would be, and then exit. This information
-# could be useful to other scripts.
if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
exit 0
@@ -75,11 +74,10 @@ rm -rf $PRGNAM-$VERSION
tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
cd $PRGNAM-$VERSION
chown -R root:root .
-find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+find -L . -perm /111 -a \! -perm 755 -a -exec chmod 755 {} \+ -o \
+ \! -perm /111 -a \! -perm 644 -a -exec chmod 644 {} \+
+
+sed -i 's,-llua,-llua5.1,' lgi/Makefile
# Fix this stuff with sed
sed -i \
@@ -87,7 +85,7 @@ sed -i \
-e "s|/lib/lua/|/lib$LIBDIRSUFFIX/lua/|" \
lgi/Makefile
-make PREFIX=/usr CFLAGS="$SLKCFLAGS"
+make PREFIX=/usr CFLAGS="$SLKCFLAGS" LUA_CFLAGS="-I/usr/include/lua5.1"
make install DESTDIR=$PKG
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
diff --git a/libraries/lgi/lgi.info b/libraries/lgi/lgi.info
index f7a72a3aa481..d1c7eb3bbb77 100644
--- a/libraries/lgi/lgi.info
+++ b/libraries/lgi/lgi.info
@@ -5,6 +5,6 @@ DOWNLOAD="https://github.com/pavouk/lgi/archive/0.9.2/lgi-0.9.2.tar.gz"
MD5SUM="ad5d2e7a4427069f926f2ca472a5fe6d"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
-REQUIRES="lua"
+REQUIRES="lua51"
MAINTAINER="Heiko Rosemann"
EMAIL="heiko.rosemann@web.de"