aboutsummaryrefslogtreecommitdiff
path: root/libraries/crossguid/crossguid.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'libraries/crossguid/crossguid.SlackBuild')
-rw-r--r--libraries/crossguid/crossguid.SlackBuild37
1 files changed, 23 insertions, 14 deletions
diff --git a/libraries/crossguid/crossguid.SlackBuild b/libraries/crossguid/crossguid.SlackBuild
index 22d2ae2da7096..801b3875e3e82 100644
--- a/libraries/crossguid/crossguid.SlackBuild
+++ b/libraries/crossguid/crossguid.SlackBuild
@@ -2,6 +2,7 @@
# Slackware build script for crossguid
+# Copyright 2023 Steven Voges <Oregon, USA>
# Copyright 2016 Larry Hajali <larryhaja[at]gmail[dot]com>
# All rights reserved.
#
@@ -25,8 +26,8 @@
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=crossguid
-VERSION=${VERSION:-20160705}
-MD5LONG=fef89a4174a7bf8cd99fa9154864ce9e8e3bf989
+VERSION=${VERSION:-20190529_ca1bf4b}
+SRCVER=${SRCVER:-ca1bf4b810e2d188d04cb6286f957008ee1b7681}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -39,9 +40,6 @@ if [ -z "$ARCH" ]; then
esac
fi
-# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
-# the name of the created package would be, and then exit. This information
-# could be useful to other scripts.
if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
exit 0
@@ -70,9 +68,9 @@ set -e
rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
-rm -rf $PRGNAM-$MD5LONG
-tar xvf $CWD/$PRGNAM-$MD5LONG.tar.gz
-cd $PRGNAM-$MD5LONG
+rm -rf $PRGNAM-$SRCVER
+tar xvf $CWD/$PRGNAM-$SRCVER.tar.gz
+cd $PRGNAM-$SRCVER
chown -R root:root .
find -L . \
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
@@ -80,17 +78,28 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-cp $CWD/Makefile.$PRGNAM Makefile
-
-CXXFLAGS="$SLKCFLAGS" \
-make
-make install DESTDIR=$PKG LIBDIR=/usr/lib${LIBDIRSUFFIX}
+#Fix compile on -current/gcc13
+sed -i '26i #include <cstdint>' src/guid.cpp
+sed -i '1i #include <cstdint>' test/TestMain.cpp
+sed -i '1i #include <cstdint>' test/Test.cpp
+
+mkdir -p build
+cd build
+ cmake \
+ -DCMAKE_C_FLAGS:STRING="$SLKCFLAGS" \
+ -DCMAKE_CXX_FLAGS:STRING="$SLKCFLAGS" \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_BUILD_TYPE=Release ..
+ make
+ make install/strip DESTDIR=$PKG
+cd ..
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a LICENSE README.md $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a LICENSE README.md \
+ $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
mkdir -p $PKG/install