aboutsummaryrefslogtreecommitdiff
path: root/graphics/tclblt/patches/usetclint.patch
diff options
context:
space:
mode:
Diffstat (limited to 'graphics/tclblt/patches/usetclint.patch')
-rw-r--r--graphics/tclblt/patches/usetclint.patch26
1 files changed, 26 insertions, 0 deletions
diff --git a/graphics/tclblt/patches/usetclint.patch b/graphics/tclblt/patches/usetclint.patch
new file mode 100644
index 0000000000000..fb51b11b847a9
--- /dev/null
+++ b/graphics/tclblt/patches/usetclint.patch
@@ -0,0 +1,26 @@
+Description: Patch adds missing headers which helps building BLT on
+ 64-bit architectures.
+Author: Matthias Klose
+Last-Modified: Sun, 06 Jul 2014 07:28:14 +0400
+
+--- a/generic/bltNsUtil.c
++++ b/generic/bltNsUtil.c
+@@ -27,6 +27,8 @@
+
+ #include "bltInt.h"
+ #include "bltList.h"
++#include "bltNsUtil.h"
++#include "tclInt.h"
+
+ /* Namespace related routines */
+
+--- a/configure.in
++++ b/configure.in
+@@ -825,6 +825,7 @@
+ "${TCL_INC_DIR}" != "${TK_INC_DIR}" ; then
+ INC_SPECS="${INC_SPECS} -I${TCL_INC_DIR}"
+ fi
++INC_SPECS="${INC_SPECS} -I${TCL_SRC_DIR}/generic -I${TCL_SRC_DIR}/unix"
+
+
+ # On Windows, override the default include directory with our own.