aboutsummaryrefslogtreecommitdiff
path: root/gis
diff options
context:
space:
mode:
Diffstat (limited to 'gis')
-rw-r--r--gis/geojson/geojson.SlackBuild5
1 files changed, 4 insertions, 1 deletions
diff --git a/gis/geojson/geojson.SlackBuild b/gis/geojson/geojson.SlackBuild
index 3ce4921bff5d..61e2f26e3a4a 100644
--- a/gis/geojson/geojson.SlackBuild
+++ b/gis/geojson/geojson.SlackBuild
@@ -67,9 +67,12 @@ find -L . \
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
-o -perm 511 \) -exec chmod 755 {} \; -o \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
python setup.py install --root=$PKG
+if $(python3 -c 'import sys' 2>/dev/null); then
+ python3 setup.py install --root=$PKG
+fi
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | \
grep ELF | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true