aboutsummaryrefslogtreecommitdiff
path: root/gis/python3-pyproj/python3-pyproj.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'gis/python3-pyproj/python3-pyproj.SlackBuild')
-rw-r--r--gis/python3-pyproj/python3-pyproj.SlackBuild7
1 files changed, 5 insertions, 2 deletions
diff --git a/gis/python3-pyproj/python3-pyproj.SlackBuild b/gis/python3-pyproj/python3-pyproj.SlackBuild
index 78bebd6211dce..8ce3614531c77 100644
--- a/gis/python3-pyproj/python3-pyproj.SlackBuild
+++ b/gis/python3-pyproj/python3-pyproj.SlackBuild
@@ -26,7 +26,7 @@
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=python3-pyproj
-VERSION=${VERSION:-3.5.0}
+VERSION=${VERSION:-3.6.0}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -82,7 +82,10 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-python3 setup.py install --root=$PKG
+export PYTHONPATH=/opt/python3.9/site-packages
+
+python3 -m build --no-isolation
+python3 -m installer -d "$PKG" dist/*.whl
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true