aboutsummaryrefslogtreecommitdiff
path: root/gis/python3-netcdf4-python/python3-netcdf4-python.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'gis/python3-netcdf4-python/python3-netcdf4-python.SlackBuild')
-rw-r--r--gis/python3-netcdf4-python/python3-netcdf4-python.SlackBuild8
1 files changed, 3 insertions, 5 deletions
diff --git a/gis/python3-netcdf4-python/python3-netcdf4-python.SlackBuild b/gis/python3-netcdf4-python/python3-netcdf4-python.SlackBuild
index 1ae1f1e3549e8..3a0ac454f05eb 100644
--- a/gis/python3-netcdf4-python/python3-netcdf4-python.SlackBuild
+++ b/gis/python3-netcdf4-python/python3-netcdf4-python.SlackBuild
@@ -25,7 +25,7 @@
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=python3-netcdf4-python
-VERSION=${VERSION:-1.6.4}
+VERSION=${VERSION:-1.6.5}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -60,10 +60,8 @@ tar xvf $CWD/$SRCNAM-$SRCVER.tar.gz
cd $SRCNAM-$SRCVER
chown -R root:root .
find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+ -perm /111 -a \! -perm 755 -a -exec chmod 755 {} + -o \
+ \! -perm /111 -a \! -perm 644 -a -exec chmod 644 {} +
# Fixing numpy dependency check in pyproject.toml:
# oldest-supported-numpy has a strict check and doesn't support newer version