aboutsummaryrefslogtreecommitdiff
path: root/gis/Shapely/Shapely.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'gis/Shapely/Shapely.SlackBuild')
-rw-r--r--gis/Shapely/Shapely.SlackBuild8
1 files changed, 4 insertions, 4 deletions
diff --git a/gis/Shapely/Shapely.SlackBuild b/gis/Shapely/Shapely.SlackBuild
index 54dcd36f11c8e..3f32e523b79d9 100644
--- a/gis/Shapely/Shapely.SlackBuild
+++ b/gis/Shapely/Shapely.SlackBuild
@@ -3,7 +3,7 @@
# Slackware build script for Shapely
# Copyright 2013-2020 Benjamin Trigona-Harany <slackbuilds@jaxartes.net>
-# Copyright 2021 Gregory J. L. Tourte <artourter@gmail.com>
+# Copyright 2021-2022 Gregory J. L. Tourte <artourter@gmail.com>
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -75,13 +75,13 @@ tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
cd $PRGNAM-$VERSION
chown -R root:root .
find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
-o -perm 511 \) -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
# remove unnecessary .pxi file
-sed -i "s/data_files\s*=.*/data_files = [],/g" setup.py
+sed -i '/include_package_data=/s/True/False/' setup.py
python3 setup.py install --root=$PKG