aboutsummaryrefslogtreecommitdiff
path: root/games/yabause/yabause.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'games/yabause/yabause.SlackBuild')
-rw-r--r--games/yabause/yabause.SlackBuild7
1 files changed, 3 insertions, 4 deletions
diff --git a/games/yabause/yabause.SlackBuild b/games/yabause/yabause.SlackBuild
index c7b82f73eb7e8..8e5e155aeedbf 100644
--- a/games/yabause/yabause.SlackBuild
+++ b/games/yabause/yabause.SlackBuild
@@ -79,10 +79,7 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \+
-# Variable to determine gtk/qt interface. Default is qt.
-# 20220221 bkw: hardcoded to gtk, because qt won't build on Slackware 15.0.
-# Possibly it would with qt4, but not qt5.
-USE_GUI=gtk
+USE_GUI=qt
# Fix location of man file.
sed -i 's|share/man|man|' src/CMakeLists.txt
@@ -97,6 +94,8 @@ done
# Patch against ffmpeg 3
patch -p1 < $CWD/ffmpeg3.patch
+patch -p1 < $CWD/qt-5.11.patch
+
mkdir build
cd build
cmake -G "Unix Makefiles" \