aboutsummaryrefslogtreecommitdiff
path: root/games/m64py/m64py.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'games/m64py/m64py.SlackBuild')
-rw-r--r--games/m64py/m64py.SlackBuild5
1 files changed, 4 insertions, 1 deletions
diff --git a/games/m64py/m64py.SlackBuild b/games/m64py/m64py.SlackBuild
index 8012ec4eaeafd..3aa7ff6414b3b 100644
--- a/games/m64py/m64py.SlackBuild
+++ b/games/m64py/m64py.SlackBuild
@@ -26,7 +26,7 @@ cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=m64py
VERSION=${VERSION:-0.2.5}
-BUILD=${BUILD:-1}
+BUILD=${BUILD:-2}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -76,6 +76,9 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+patch -p0 < $CWD/fix_setup_py.patch
+patch -p1 < $CWD/fix_core_dump_by_int_cast.patch
+
python3 setup.py install --root=$PKG
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \