aboutsummaryrefslogtreecommitdiff
path: root/development
diff options
context:
space:
mode:
Diffstat (limited to 'development')
-rw-r--r--development/perf/perf.SlackBuild4
1 files changed, 2 insertions, 2 deletions
diff --git a/development/perf/perf.SlackBuild b/development/perf/perf.SlackBuild
index 10bf118b94ffe..b67fa20209943 100644
--- a/development/perf/perf.SlackBuild
+++ b/development/perf/perf.SlackBuild
@@ -88,11 +88,11 @@ EOF
case "$KERNEL" in
# if unset, use the running kernel:
- "") SRCDIR="/usr/src/linux-$( uname -r )" ;;
+ "") SRCDIR="/usr/src/linux-$( uname -r )" ; SRCDIR=${SRCDIR%-smp} ;;
# if it's an absolute path, use it as-is:
/*) SRCDIR="$KERNEL" ;;
# otherwise assume it's a version number:
- *) SRCDIR="/usr/src/linux-$KERNEL" ;;
+ *) KERNEL=${KERNEL%-smp} ; SRCDIR="/usr/src/linux-$KERNEL" ;;
esac
[ -f "$SRCDIR/Makefile" ] || die "Can't find kernel source in \"$SRCDIR\""