aboutsummaryrefslogtreecommitdiff
path: root/development
diff options
context:
space:
mode:
Diffstat (limited to 'development')
-rw-r--r--development/codespell/README4
-rw-r--r--development/codespell/codespell.SlackBuild16
-rw-r--r--development/codespell/codespell.info8
3 files changed, 17 insertions, 11 deletions
diff --git a/development/codespell/README b/development/codespell/README
index 9c3f66cbb86bc..cdbc979cecfb8 100644
--- a/development/codespell/README
+++ b/development/codespell/README
@@ -3,7 +3,3 @@ codespell (spell checker for source code)
codespell fixes common misspellings in text files. It's designed
primarily for checking misspelled words in source code, but it can be
used with other files as well.
-
-Note: This is not the latest version of codespell. Version 2.2.2
-can't be built on Slackware 15.0 due to needing too new of a
-python-setuptools (I'm told it works on -current).
diff --git a/development/codespell/codespell.SlackBuild b/development/codespell/codespell.SlackBuild
index ddcead8fd2926..e09e2ade49b96 100644
--- a/development/codespell/codespell.SlackBuild
+++ b/development/codespell/codespell.SlackBuild
@@ -6,7 +6,12 @@
# Licensed under the WTFPL. See http://www.wtfpl.net/txt/copying/ for details.
+# 20230820 bkw: update for 2.2.5, *many* thanks to fourtysixandtwo for
+# his python3-setuptools-opt build, and for figuring out the bug in
+# this build's pyproject.toml.
+
# 20230115 bkw: update for 2.2.1, not the latest (see README).
+
# 20210829 bkw:
# - update for 2.1.0.
# - use python3 by default. add PYVER var to force building with 2,
@@ -16,7 +21,7 @@
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=codespell
-VERSION=${VERSION:-2.2.1}
+VERSION=${VERSION:-2.2.5}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -47,8 +52,13 @@ rm -rf $PRGNAM-$VERSION
tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
cd $PRGNAM-$VERSION
chown -R root:root .
-find -L . -perm /111 -a \! -perm 755 -a -exec chmod 755 {} \+ -o \
- \! -perm /111 -a \! -perm 644 -a -exec chmod 644 {} \+
+find -L . -perm /111 -a \! -perm 755 -a -exec chmod 755 {} + -o \
+ \! -perm /111 -a \! -perm 644 -a -exec chmod 644 {} +
+
+# write_to directive is broken, turns out we can do without it.
+sed -i '/^write_to/d' pyproject.toml
+
+export PYTHONPATH=/opt/python3.9/site-packages/
python3 -m build --no-isolation
python3 -m installer -d "$PKG" dist/*.whl
diff --git a/development/codespell/codespell.info b/development/codespell/codespell.info
index 9eaa7aababd32..e53bd2f693110 100644
--- a/development/codespell/codespell.info
+++ b/development/codespell/codespell.info
@@ -1,10 +1,10 @@
PRGNAM="codespell"
-VERSION="2.2.1"
+VERSION="2.2.5"
HOMEPAGE="https://pypi.org/project/codespell/"
-DOWNLOAD="https://files.pythonhosted.org/packages/source/c/codespell/codespell-2.2.1.tar.gz"
-MD5SUM="7ae59ee609a991ed1f1a3e5073d31260"
+DOWNLOAD="https://files.pythonhosted.org/packages/source/c/codespell/codespell-2.2.5.tar.gz"
+MD5SUM="b687c2864c0b6a15553e32d6b2b07757"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
-REQUIRES="python3-build python3-wheel"
+REQUIRES="python3-setuptools-opt"
MAINTAINER="B. Watson"
EMAIL="urchlay@slackware.uk"