aboutsummaryrefslogtreecommitdiff
path: root/development/python3-matplotlib/python3-matplotlib.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'development/python3-matplotlib/python3-matplotlib.SlackBuild')
-rw-r--r--development/python3-matplotlib/python3-matplotlib.SlackBuild8
1 files changed, 3 insertions, 5 deletions
diff --git a/development/python3-matplotlib/python3-matplotlib.SlackBuild b/development/python3-matplotlib/python3-matplotlib.SlackBuild
index 829d1caa30..419a58e216 100644
--- a/development/python3-matplotlib/python3-matplotlib.SlackBuild
+++ b/development/python3-matplotlib/python3-matplotlib.SlackBuild
@@ -71,6 +71,9 @@ cd $TMP
rm -rf $SRCNAM-$TARBALL_VERSION
tar xvf $CWD/$SRCNAM-$VERSION.tar.gz
cd $SRCNAM-$TARBALL_VERSION
+mkdir -p build
+tar -C build -xvf $CWD/freetype-2.6.1.tar.gz
+tar -C build -xvf $CWD/qhull-2020-src-8.0.2.tgz
chown -R root:root .
find -L . \
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
@@ -87,11 +90,6 @@ then
sed -i "s|#tests = False|tests = True|" setup.cfg
fi
-# Use modified setupext.py to make sure that the build process gets
-# interrupted if requirements are not fulfilled
-#
-#cat "${CWD}/setupext.py" > setupext.py
-
python3 setup.py install --root $PKG # > ${CWD}/SETUP.OUTPUT 2>&1
find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \