aboutsummaryrefslogtreecommitdiff
path: root/desktop/xpra/xpra.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'desktop/xpra/xpra.SlackBuild')
-rw-r--r--desktop/xpra/xpra.SlackBuild31
1 files changed, 25 insertions, 6 deletions
diff --git a/desktop/xpra/xpra.SlackBuild b/desktop/xpra/xpra.SlackBuild
index 98d1017726627..4c0239070a7d0 100644
--- a/desktop/xpra/xpra.SlackBuild
+++ b/desktop/xpra/xpra.SlackBuild
@@ -6,6 +6,9 @@
# Licensed under the WTFPL. See http://www.wtfpl.net/txt/copying/ for details.
+# 20240126 bkw: update for v5.0.4.
+# - add xpra-html5-10.1, by request from Andrew Randrianasulu.
+# - make the config files .new!
# 20230112 bkw: update for v4.4.3.
# 20221217 bkw: BUILD=2.
# - fix paths in config file (do not include $PKG).
@@ -13,7 +16,8 @@
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=xpra
-VERSION=${VERSION:-4.4.3}
+VERSION=${VERSION:-5.0.4}
+HTML5VER=${HTML5VER:-10.1}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -46,13 +50,11 @@ cd $TMP
rm -rf $PRGNAM-$VERSION
tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
cd $PRGNAM-$VERSION
+tar xvf $CWD/xpra-html5-$HTML5VER.tar.gz
tar xvf $CWD/$PRGNAM-$VERSION-prebuilt-docs.tar.xz
chown -R root:root .
-find -L . -perm /111 -a \! -perm 755 -a -exec chmod 755 {} \+ -o \
- \! -perm /111 -a \! -perm 644 -a -exec chmod 644 {} \+
-
-# setup.py is slightly broken...
-patch -p1 < $CWD/setup_cuda_bin.diff
+find -L . -perm /111 -a \! -perm 755 -a -exec chmod 755 {} + -o \
+ \! -perm /111 -a \! -perm 644 -a -exec chmod 644 {} +
sed -i 's,"share/man","man",' setup.py
@@ -107,9 +109,26 @@ mkdir -p $PKGDOC/html
# prebuilt docs. See mkdoc.sh for details.
cp -a $PRGNAM-$VERSION-prebuilt-docs/* $PKGDOC/html
+# 20240127 bkw: include the html5 server-side stuff.
+# Nonstandard setup.py, uses positional arguments, undocumented.
+# Adapted from packaging/rpm/xpra-html5.spec in the xpra-html5 src, and
+# from looking at the finished rpm package. See also the doinst.sh!
+cd xpra-html5-$HTML5VER
+ python3 setup.py install $PKG /usr/share/xpra/www/ /etc/xpra/html5-client copy
+ mkdir $PKGDOC/xpra-html5-$HTML5VER
+ # The RPM doesn't include these, but they look useful:
+ cp -a LICENSE *.md docs $PKGDOC/xpra-html5-$HTML5VER
+cd -
+
cp -a COPYING README.md $PKGDOC
cat $CWD/$PRGNAM.SlackBuild > $PKGDOC/$PRGNAM.SlackBuild
+# 20240127 bkw: lots of config files. Maybe not all of them are really meant
+# to be user-edited, but it's easier to treat them all the same way here.
+find $PKG/etc/xpra -type f | while read f; do
+ mv $f $f.new
+done
+
mkdir -p $PKG/install
cat $CWD/slack-desc > $PKG/install/slack-desc
cat $CWD/doinst.sh > $PKG/install/doinst.sh