aboutsummaryrefslogtreecommitdiff
path: root/desktop/xpra/xpra.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'desktop/xpra/xpra.SlackBuild')
-rw-r--r--desktop/xpra/xpra.SlackBuild23
1 files changed, 21 insertions, 2 deletions
diff --git a/desktop/xpra/xpra.SlackBuild b/desktop/xpra/xpra.SlackBuild
index 5635d9f4a459b..d1becaa397089 100644
--- a/desktop/xpra/xpra.SlackBuild
+++ b/desktop/xpra/xpra.SlackBuild
@@ -6,14 +6,15 @@
# Licensed under the WTFPL. See http://www.wtfpl.net/txt/copying/ for details.
+# 20230112 bkw: update for v4.4.3.
# 20221217 bkw: BUILD=2.
# - fix paths in config file (do not include $PKG).
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=xpra
-VERSION=${VERSION:-4.3}
-BUILD=${BUILD:-2}
+VERSION=${VERSION:-4.4.3}
+BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -51,11 +52,16 @@ chown -R root:root .
find -L . -perm /111 -a \! -perm 755 -a -exec chmod 755 {} \+ -o \
\! -perm /111 -a \! -perm 644 -a -exec chmod 644 {} \+
+# setup.py is slightly broken...
+patch -p1 < $CWD/setup_cuda_bin.diff
+
sed -i 's,"share/man","man",' setup.py
# without-strict turns off -Werror. without-docs because we don't want
# pandoc *and its 139 deps* as a dependency. Include prebuilt docs
# instead.
+# 20230112 bkw: pandoc now has 196 deps... Could use pandoc-bin, but
+# it doesn't do 32-bit. Still using prebuilt docs for now.
python3 setup.py install \
--root=$PKG \
--without-docs \
@@ -65,6 +71,19 @@ python3 setup.py install \
# 20221217 bkw: grrr. $PKG getting hardcoded in config file.
sed -i "s,$PKG,,g" $PKG/etc/xpra/conf.d/55_server_x11.conf
+# 20230112 bkw: a few things are getting installed in the wrong place.
+mkdir -p $PKG/lib
+mv $PKG/usr/lib/udev $PKG/lib
+if [ -d $PKG/usr/lib64 ]; then
+ mv $PKG/usr/lib/cups $PKG/usr/lib64
+fi
+
+# /usr/lib/{sysusers.d,tmpfiles.d} are for systemd. Apparently they
+# are in the correct place, I'll leave them there (they won't hurt
+# anything and apparently there are Slackware derivatives that use
+# systemd).
+# rm -rf $PKG/usr/lib/{sysusers.d,tmpfiles.d}
+
# This is *much* faster than using 'file' to classify them.
find $PKG/usr/lib* -name '*.so' | xargs strip --strip-unneeded