aboutsummaryrefslogtreecommitdiff
path: root/audio/musicmanager/musicmanager.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'audio/musicmanager/musicmanager.SlackBuild')
-rw-r--r--audio/musicmanager/musicmanager.SlackBuild35
1 files changed, 19 insertions, 16 deletions
diff --git a/audio/musicmanager/musicmanager.SlackBuild b/audio/musicmanager/musicmanager.SlackBuild
index ad2d63bf99e18..89ac0d3059f65 100644
--- a/audio/musicmanager/musicmanager.SlackBuild
+++ b/audio/musicmanager/musicmanager.SlackBuild
@@ -2,11 +2,10 @@
# Slackware build script for Goggles Music Manager
-# Modified by disturbed1976@gmail.com
-#
+# Writen by disturbed1976@gmail.com
PRGNAM=musicmanager
-VERSION=0.9.15
+VERSION=0.10.0
ARCH=${ARCH:-i486}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -18,10 +17,14 @@ OUTPUT=${OUTPUT:-/tmp}
if [ "$ARCH" = "i486" ]; then
SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+ LIBDIRSUFFIX=""
elif [ "$ARCH" = "i686" ]; then
SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
elif [ "$ARCH" = "x86_64" ]; then
SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+ SLKLDFLAGS="-L/usr/lib${LIBDIRSUFFIX}"
fi
set -e
@@ -39,26 +42,26 @@ find . \
\( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
-exec chmod 644 {} \;
+
+patch < $CWD/Makefile.patch
+
CFLAGS="$SLKCFLAGS" \
CXXFLAGS="$SLKCFLAGS" \
+LDFLAGS="$SLKLDFLAGS" \
./configure \
- --prefix=/usr
-
-
-# Makefile will attempt to run gtk-update-icon-cache on make install.
-# This will remove that issue.
-
-patch Makefile <<EOF
-194d193
-< gtk-update-icon-cache \$(INSTALLDIR)/share/icons/hicolor
-EOF
+ --prefix=/usr \
+ --libdir=/usr/lib${LIBDIRSUFFIX} \
+ --host=$ARCH-slackware-linux \
+ --build=$ARCH-slackware-linux
-make
+make
make install DESTDIR=$PKG
( cd $PKG
- find . | xargs file | grep "executable" | grep ELF | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
- find . | xargs file | grep "shared object" | grep ELF | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null
+ find . | xargs file | grep "executable" | grep ELF | cut -f 1 -d : | \
+ xargs strip --strip-unneeded 2> /dev/null || true
+ find . | xargs file | grep "shared object" | grep ELF | cut -f 1 -d : | \
+ xargs strip --strip-unneeded 2> /dev/null
)