aboutsummaryrefslogtreecommitdiff
path: root/audio/moc/moc.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'audio/moc/moc.SlackBuild')
-rw-r--r--audio/moc/moc.SlackBuild33
1 files changed, 14 insertions, 19 deletions
diff --git a/audio/moc/moc.SlackBuild b/audio/moc/moc.SlackBuild
index 2268b923706b..1ec6aee561cd 100644
--- a/audio/moc/moc.SlackBuild
+++ b/audio/moc/moc.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for moc
-# (C) 2007 Michael Wagner <lapinours@web.de>
+# (C) 2009 Michael Wagner <slackware.wagnerm@arcor.de>
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -23,9 +23,9 @@
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
PRGNAM=moc
-VERSION=2.4.3
+VERSION=2.4.4
ARCH=${ARCH:-i486}
-BUILD=${BUILD:-2}
+BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
CWD=$(pwd)
@@ -33,15 +33,15 @@ TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
-DOCS="AUTHORS COPYING ChangeLog INSTALL NEWS README THANKS TODO \
- config.example keymap.example"
-
if [ "$ARCH" = "i486" ]; then
SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+ LIBDIRSUFFIX=""
elif [ "$ARCH" = "i686" ]; then
SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
elif [ "$ARCH" = "x86_64" ]; then
SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
fi
set -e
@@ -59,30 +59,25 @@ find . \
\( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
-exec chmod 644 {} \;
-# Patch configure.in and ffmpeg.c for use with newer
-# ffmpeg versions
-patch -p0 < $CWD/configure.in.diff
-patch -p0 < $CWD/ffmpeg.c.diff
-
-aclocal -I m4 && automake && autoconf
+# Get --docdir working
+sed -i 's,$(datadir)/doc/$(PACKAGE),@docdir@,' Makefile.in
CFLAGS="$SLKCFLAGS" \
CXXFLAGS="$SLKCFLAGS" \
./configure \
--prefix=/usr \
+ --docdir=/usr/doc/$PRGNAM-$VERSION \
+ --libdir=/usr/lib${LIBDIRSUFFIX} \
--mandir=/usr/man \
- --disable-debug
+ --disable-debug \
+ --disable-static \
+ --build=$ARCH-slackware-linux
make
make install-strip DESTDIR=$PKG
gzip -9 $PKG/usr/man/man1/*.?
-# Remove $PKG/usr/share/doc (the Makefile doesn't seem to understand docdir)
-rm -rf $PKG/usr/share/doc
-
-mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a $DOCS $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
chmod 644 $PKG/usr/doc/$PRGNAM-$VERSION/*
@@ -90,4 +85,4 @@ mkdir -p $PKG/install
cat $CWD/slack-desc > $PKG/install/slack-desc
cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.tgz
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}