aboutsummaryrefslogtreecommitdiff
path: root/audio/clxclient/clxclient.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'audio/clxclient/clxclient.SlackBuild')
-rw-r--r--audio/clxclient/clxclient.SlackBuild11
1 files changed, 4 insertions, 7 deletions
diff --git a/audio/clxclient/clxclient.SlackBuild b/audio/clxclient/clxclient.SlackBuild
index b86b7893f204e..bdaa861c6266e 100644
--- a/audio/clxclient/clxclient.SlackBuild
+++ b/audio/clxclient/clxclient.SlackBuild
@@ -5,7 +5,7 @@
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=clxclient
-VERSION=${VERSION:-3.9.0}
+VERSION=${VERSION:-3.9.2}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -18,9 +18,6 @@ if [ -z "$ARCH" ]; then
esac
fi
-# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
-# the name of the created package would be, and then exit. This information
-# could be useful to other scripts.
if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
exit 0
@@ -51,7 +48,7 @@ mkdir -p $TMP $PKG $OUTPUT
cd $TMP
rm -rf $PRGNAM-$VERSION
tar -xjvf $CWD/$PRGNAM-$VERSION.tar.bz2
-cd $PRGNAM-$VERSION
+cd $PRGNAM-$VERSION/source
chown -R root:root .
find -L . \
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
@@ -59,7 +56,7 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-sed -i -e 's+/usr/local+/usr+' $TMP/$PRGNAM-$VERSION/Makefile
+sed -i 's+pkgconf+pkg-config+' Makefile
CFLAGS="$SLKCFLAGS" \
CXXFLAGS="$SLKCFLAGS" \
@@ -79,7 +76,7 @@ find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | gr
cd $TMP/$PRGNAM-$VERSION
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
cp -a \
- AUTHORS COPYING INSTALL \
+ AUTHORS COPYING \
$PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild