aboutsummaryrefslogtreecommitdiff
path: root/academic/sympy/sympy.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'academic/sympy/sympy.SlackBuild')
-rw-r--r--academic/sympy/sympy.SlackBuild12
1 files changed, 6 insertions, 6 deletions
diff --git a/academic/sympy/sympy.SlackBuild b/academic/sympy/sympy.SlackBuild
index b8895004b2b2..264fcd87ac9e 100644
--- a/academic/sympy/sympy.SlackBuild
+++ b/academic/sympy/sympy.SlackBuild
@@ -7,8 +7,8 @@
# Updated for 0.7.1 by Serban Udrea <S.Udrea@gsi.de>
PRGNAM=sympy
-VERSION=${VERSION:-0.7.1}
-BUILD=${BUILD:-2}
+VERSION=${VERSION:-0.7.3}
+BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
if [ -z "$ARCH" ]; then
@@ -33,11 +33,11 @@ rm -rf $PRGNAM-$VERSION
tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
cd $PRGNAM-$VERSION
chown -R root:root .
-find . \
+find -L . \
\( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
-exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
- -exec chmod 644 {} \;
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
python setup.py install --root=$PKG
@@ -48,7 +48,7 @@ for i in $( find $PKG/usr/man -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; r
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
cp -a \
- AUTHORS LICENSE README TODO \
+ AUTHORS LICENSE TODO \
$PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild