aboutsummaryrefslogtreecommitdiff
path: root/academic/Kst/Kst.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'academic/Kst/Kst.SlackBuild')
-rw-r--r--academic/Kst/Kst.SlackBuild28
1 files changed, 25 insertions, 3 deletions
diff --git a/academic/Kst/Kst.SlackBuild b/academic/Kst/Kst.SlackBuild
index 0ae8d4632f063..25dd19977b00e 100644
--- a/academic/Kst/Kst.SlackBuild
+++ b/academic/Kst/Kst.SlackBuild
@@ -1,8 +1,27 @@
#!/bin/bash
+
# Slackware build script for Kst
-# Based on Slackware 14.1 SlackBuild and AUR PKGBUILD for Kst
-# Written by Fellype do Nascimento <fellype(at)gmail.com>
-# last modification of this build script: 2014/12/10
+# Copyright 2014-2022 Fellype do Nascimento, Guaratingueta, Brazil
+# SBo team have contributed to the maintenance of this build script :)
+#
+# Based on Slackware 15.0 SlackBuild and AUR PKGBUILD for Kst
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ''AS IS'' AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
cd $(dirname $0) ; CWD=$(pwd)
@@ -55,6 +74,9 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+# Fix the path for H5Cpp.h
+patch -p1 < $CWD/fix_hdf5_path.patch src/datasources/hdf5/hdf5.h
+
# Fix an issue with the newer cmake
sed -i "s|else(GCC|elseif(GCC|" CMakeLists.txt || exit 1