aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--python/license-expression/changelog10
-rw-r--r--python/license-expression/license-expression.SlackBuild33
-rw-r--r--python/license-expression/license-expression.info6
3 files changed, 24 insertions, 25 deletions
diff --git a/python/license-expression/changelog b/python/license-expression/changelog
deleted file mode 100644
index 79babffe19a1..000000000000
--- a/python/license-expression/changelog
+++ /dev/null
@@ -1,10 +0,0 @@
-Changelog license-expression pmdk SlackBuild Script
---------------------------------------------------------------------
-
-05/11/2022:
-
-Added to slackbuilds.org
-
-17/05/2023:
-
-Updated to version 30.1.0
diff --git a/python/license-expression/license-expression.SlackBuild b/python/license-expression/license-expression.SlackBuild
index a6160955a69c..25de4a8ce887 100644
--- a/python/license-expression/license-expression.SlackBuild
+++ b/python/license-expression/license-expression.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for license-expression
-# Copyright 2022-2023 Vijay Marcel
+# Copyright 2022-2024 Vijay Marcel
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -22,13 +22,25 @@
# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+####################################Changelog###################################
+
+# 05/11/2022: Added to slackbuilds.org
+
+# 17/05/2023: Updated to version 30.1.0
+
+# 10/04/2024: updated to version 30.3.1
+
+
+##################################################################################
+
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=license-expression
-VERSION=${VERSION:-30.1.0}
+VERSION=${VERSION:-30.3.1}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
+SRCNAM=${SRCNAM:-license_expression}
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
@@ -38,9 +50,6 @@ if [ -z "$ARCH" ]; then
esac
fi
-# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
-# the name of the created package would be, and then exit. This information
-# could be useful to other scripts.
if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
exit 0
@@ -70,9 +79,9 @@ trap 'echo "$0 FAILED at line $LINENO!" | tee -a $OUTPUT/error-${PRGNAM}.log' ER
rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
-rm -rf $PRGNAM-$VERSION
-tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
-cd $PRGNAM-$VERSION
+rm -rf $SRCNAM-$VERSION
+tar xvf $CWD/$SRCNAM-$VERSION.tar.gz
+cd $SRCNAM-$VERSION
chown -R root:root .
find -L . \
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
@@ -80,13 +89,13 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-python3 setup.py install --prefix=/usr --root=$PKG --optimize=1
+CFLAGS="$SLKCFLAGS" python3 setup.py install --prefix=/usr --root=$PKG --optimize=1
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
- | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+ | cut -f 1 -d : | xargs strip --strip-unneeded --remove-section=.comment --remove-section=.note 2> /dev/null || true
-mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a docs apache-2.0.LICENSE CHANGELOG.rst NOTICE PKG-INFO README.rst AUTHORS.rst CODE_OF_CONDUCT.rst $PKG/usr/doc/$PRGNAM-$VERSION
+mkdir -pv $PKG/usr/doc/$PRGNAM-$VERSION
+cp -av docs apache-2.0.LICENSE CHANGELOG.rst README.rst AUTHORS.rst CODE_OF_CONDUCT.rst $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
mkdir -p $PKG/install
diff --git a/python/license-expression/license-expression.info b/python/license-expression/license-expression.info
index 78b9c2c340b4..9b943ef70795 100644
--- a/python/license-expression/license-expression.info
+++ b/python/license-expression/license-expression.info
@@ -1,8 +1,8 @@
PRGNAM="license-expression"
-VERSION="30.1.0"
+VERSION="30.3.1"
HOMEPAGE="https://github.com/nexB/license-expression"
-DOWNLOAD="https://pypi.io/packages/source/l/license-expression/license-expression-30.1.0.tar.gz"
-MD5SUM="37a93065d65d511ea70c7b93d01f8cf0"
+DOWNLOAD="https://pypi.io/packages/source/l/license-expression/license_expression-30.3.1.tar.gz"
+MD5SUM="030df78064748876ca852e8b5ac0d407"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES="boolean-py"