aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--development/mmtf-cpp/README13
-rw-r--r--development/mmtf-cpp/mmtf-cpp.SlackBuild30
-rw-r--r--development/mmtf-cpp/mmtf-cpp.info4
3 files changed, 13 insertions, 34 deletions
diff --git a/development/mmtf-cpp/README b/development/mmtf-cpp/README
index 66d7afcad06d5..2ae471695ebab 100644
--- a/development/mmtf-cpp/README
+++ b/development/mmtf-cpp/README
@@ -1,10 +1,9 @@
-The MacroMolecular Transmission Format (MMTF) is a binary encoding of
-biological structures. It includes the coordinates, the topology and
-associated data. Specifically, a large subset of the data in mmCIF or
-PDB files can be represented. Pronounced goals are a reduced file size
-for efficient transmission over the Internet or from hard disk to
+The MacroMolecular Transmission Format (MMTF) is a binary encoding of
+biological structures. It includes the coordinates, the topology and
+associated data. Specifically, a large subset of the data in mmCIF or
+PDB files can be represented. Pronounced goals are a reduced file size
+for efficient transmission over the Internet or from hard disk to
memory and fast decoding/parsing speed.
-This slackbuild does not compile but install the C++ headers needed to
+This slackbuild does not compile but install the C++ headers needed to
compile sources that supports it, e.g. Avogadro 2.
-
diff --git a/development/mmtf-cpp/mmtf-cpp.SlackBuild b/development/mmtf-cpp/mmtf-cpp.SlackBuild
index 99674bc6608ec..deef578dfc9d3 100644
--- a/development/mmtf-cpp/mmtf-cpp.SlackBuild
+++ b/development/mmtf-cpp/mmtf-cpp.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for mmtf-cpp
-# Copyright 2020-2022 Giancarlo Dessì, Cagliari, IT
+# Copyright 2020-2024 Giancarlo Dessì, Cagliari, IT
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -26,17 +26,11 @@ cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=mmtf-cpp
VERSION=${VERSION:-1.1.0}
-BUILD=${BUILD:-1}
+BUILD=${BUILD:-2}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
-if [ -z "$ARCH" ]; then
- case "$( uname -m )" in
- i?86) ARCH=i586 ;;
- arm*) ARCH=arm ;;
- *) ARCH=$( uname -m ) ;;
- esac
-fi
+ARCH=noarch
if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
@@ -47,20 +41,6 @@ TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
-if [ "$ARCH" = "i586" ]; then
- SLKCFLAGS="-O2 -march=i586 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "i686" ]; then
- SLKCFLAGS="-O2 -march=i686 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "x86_64" ]; then
- SLKCFLAGS="-O2 -fPIC"
- LIBDIRSUFFIX="64"
-else
- SLKCFLAGS="-O2"
- LIBDIRSUFFIX=""
-fi
-
set -e
rm -rf $PKG
@@ -75,6 +55,8 @@ find -L . \
-o -perm 511 \) -exec chmod 755 {} \; -o \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+sed -i ./CMakeLists.txt -e "s/find_package(msgpack)/find_package(msgpack-cxx)/g"
mkdir -p build
cd build
@@ -82,8 +64,6 @@ cd build
DESTDIR=$PKG ninja install
cd ..
-rm -f $PKG/{,usr/}lib${LIBDIRSUFFIX}/*.la
-
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
diff --git a/development/mmtf-cpp/mmtf-cpp.info b/development/mmtf-cpp/mmtf-cpp.info
index 194a4c5092586..d6b2d66473b37 100644
--- a/development/mmtf-cpp/mmtf-cpp.info
+++ b/development/mmtf-cpp/mmtf-cpp.info
@@ -5,6 +5,6 @@ DOWNLOAD="https://github.com/rcsb/mmtf-cpp/archive/v1.1.0/mmtf-cpp-1.1.0.tar.gz"
MD5SUM="ec961ff406a1636b4c5a25de7d9bd47b"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
-REQUIRES="msgpack-c"
-MAINTAINER="Giancarlo Dessì"
+REQUIRES="msgpack-c-cpp"
+MAINTAINER="Giancarlo Dessi"
EMAIL="slack@giand.it"