aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gis/python3-cartopy/python3-cartopy.SlackBuild12
-rw-r--r--gis/python3-cartopy/python3-cartopy.info8
2 files changed, 9 insertions, 11 deletions
diff --git a/gis/python3-cartopy/python3-cartopy.SlackBuild b/gis/python3-cartopy/python3-cartopy.SlackBuild
index 42993d57966b..4dcce22bbbe2 100644
--- a/gis/python3-cartopy/python3-cartopy.SlackBuild
+++ b/gis/python3-cartopy/python3-cartopy.SlackBuild
@@ -3,7 +3,7 @@
# Slackware build script for python3-cartopy
# Copyright 2014-2021 Benjamin Trigona-Harany <slackbuilds@jaxartes.net>
-# Copyright 2021-2023 Gregory J. L. Tourte <artourter@gmail.com>
+# Copyright 2021-2024 Gregory J. L. Tourte <artourter@gmail.com>
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -26,7 +26,7 @@
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=python3-cartopy
-VERSION=${VERSION:-0.22.0}
+VERSION=${VERSION:-0.23.0}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -81,10 +81,8 @@ find -L . \
\! -perm /111 -o \! -perm 644 -o -exec chmod 644 {} +
# Fixing numpy dependency check in pyproject.toml:
-# oldest-supported-numpy has a strict check and doesn't support newer version
-# so we replace it. The alternative is to add --skip-dependency-check to tbe
-# build line but this is not deemed optimal.
-sed -i 's/oldest-supported-numpy/numpy>=1.19.3/' pyproject.toml
+# numpy 2.0.0 is requested for building the pypi packages but numpy 1.x is supported.
+sed -i 's/numpy>=2.0.0rc1/numpy>=1.19.3/' pyproject.toml
PYVER=$(python3 -c 'import sys; print("%d.%d" % sys.version_info[:2])')
export PYTHONPATH=/opt/python$PYVER/site-packages/
@@ -97,7 +95,7 @@ find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | \
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
cp -a \
- CHANGES COPYING COPYING.LESSER README.md \
+ CHANGES LICENSE README.md \
$PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
diff --git a/gis/python3-cartopy/python3-cartopy.info b/gis/python3-cartopy/python3-cartopy.info
index 19dbf3eaedeb..363dedfbfa5f 100644
--- a/gis/python3-cartopy/python3-cartopy.info
+++ b/gis/python3-cartopy/python3-cartopy.info
@@ -1,8 +1,8 @@
PRGNAM="python3-cartopy"
-VERSION="0.22.0"
-HOMEPAGE="https://scitools.org.uk/cartopy/"
-DOWNLOAD="https://files.pythonhosted.org/packages/source/C/Cartopy/Cartopy-0.22.0.tar.gz"
-MD5SUM="1a96bec92d02a0f9c95fa6364cb0767d"
+VERSION="0.23.0"
+HOMEPAGE="https://scitools.org.uk/cartopy/docs/latest"
+DOWNLOAD="https://files.pythonhosted.org/packages/source/C/Cartopy/Cartopy-0.23.0.tar.gz"
+MD5SUM="8ff6ac2bad287d2575f3857f169d6bcf"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES="gdal python3-matplotlib python3-pyproj python3-pyshp python3-scipy python3-shapely python3-setuptools-scm-opt"