aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--python/python3-tgext.routes/README (renamed from python/tgext.routes/README)0
-rw-r--r--python/python3-tgext.routes/python3-tgext.routes.SlackBuild (renamed from python/tgext.routes/tgext.routes.SlackBuild)16
-rw-r--r--python/python3-tgext.routes/python3-tgext.routes.info (renamed from python/tgext.routes/tgext.routes.info)10
-rw-r--r--python/python3-tgext.routes/slack-desc19
-rw-r--r--python/tgext.routes/slack-desc19
5 files changed, 31 insertions, 33 deletions
diff --git a/python/tgext.routes/README b/python/python3-tgext.routes/README
index e67a13791e3eb..e67a13791e3eb 100644
--- a/python/tgext.routes/README
+++ b/python/python3-tgext.routes/README
diff --git a/python/tgext.routes/tgext.routes.SlackBuild b/python/python3-tgext.routes/python3-tgext.routes.SlackBuild
index 86182f45d27eb..ca30a5e639486 100644
--- a/python/tgext.routes/tgext.routes.SlackBuild
+++ b/python/python3-tgext.routes/python3-tgext.routes.SlackBuild
@@ -22,8 +22,9 @@
cd $(dirname $0) ; CWD=$(pwd)
-PRGNAM=tgext.routes
-VERSION=${VERSION:-0.2.0}
+PRGNAM=python3-tgext.routes
+SRCNAM=${PRGNAM#python3-*}
+VERSION=${VERSION:-0.2.1}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -53,9 +54,9 @@ set -e
rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
-rm -rf $PRGNAM-$VERSION
-tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
-cd $PRGNAM-$VERSION
+rm -rf $SRCNAM-$VERSION
+tar xvf $CWD/$SRCNAM-$VERSION.tar.gz
+cd $SRCNAM-$VERSION
chown -R root:root .
find -L . \
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
@@ -63,10 +64,7 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-python setup.py install --root=$PKG
-if $(python3 -c 'import sys' 2>/dev/null); then
- python3 setup.py install --root=$PKG
-fi
+python3 setup.py install --root=$PKG
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
cp -a README* $PKG/usr/doc/$PRGNAM-$VERSION
diff --git a/python/tgext.routes/tgext.routes.info b/python/python3-tgext.routes/python3-tgext.routes.info
index a2abd9d840f49..23988c2770b83 100644
--- a/python/tgext.routes/tgext.routes.info
+++ b/python/python3-tgext.routes/python3-tgext.routes.info
@@ -1,10 +1,10 @@
-PRGNAM="tgext.routes"
-VERSION="0.2.0"
+PRGNAM="python3-tgext.routes"
+VERSION="0.2.1"
HOMEPAGE="https://github.com/TurboGears/tgext.routes"
-DOWNLOAD="https://pypi.python.org/packages/source/t/tgext.routes/tgext.routes-0.2.0.tar.gz"
-MD5SUM="34b78875b42d0909d93d9c3c328fa12a"
+DOWNLOAD="https://pypi.python.org/packages/source/t/tgext.routes/tgext.routes-0.2.1.tar.gz"
+MD5SUM="94ee4e29e458fd8fbfd92c68245551d8"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
-REQUIRES=""
+REQUIRES="python3-routes python3-turbogears2"
MAINTAINER="Yth - Arnaud"
EMAIL="yth@ythogtha.org"
diff --git a/python/python3-tgext.routes/slack-desc b/python/python3-tgext.routes/slack-desc
new file mode 100644
index 0000000000000..1c40c9ccf740b
--- /dev/null
+++ b/python/python3-tgext.routes/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+python3-tgext.routes: python3-tgext.routes (Python Module)
+python3-tgext.routes:
+python3-tgext.routes: Provides Routes based dispatching for TurboGears2
+python3-tgext.routes:
+python3-tgext.routes:
+python3-tgext.routes:
+python3-tgext.routes:
+python3-tgext.routes:
+python3-tgext.routes:
+python3-tgext.routes:
+python3-tgext.routes:
diff --git a/python/tgext.routes/slack-desc b/python/tgext.routes/slack-desc
deleted file mode 100644
index dd2504012a20d..0000000000000
--- a/python/tgext.routes/slack-desc
+++ /dev/null
@@ -1,19 +0,0 @@
-# HOW TO EDIT THIS FILE:
-# The "handy ruler" below makes it easier to edit a package description.
-# Line up the first '|' above the ':' following the base package name, and
-# the '|' on the right side marks the last column you can put a character in.
-# You must make exactly 11 lines for the formatting to be correct. It's also
-# customary to leave one space after the ':' except on otherwise blank lines.
-
- |-----handy-ruler------------------------------------------------------|
-tgext.routes: tgext.routes (Python Module)
-tgext.routes:
-tgext.routes: Provides Routes based dispatching for TurboGears2
-tgext.routes:
-tgext.routes:
-tgext.routes:
-tgext.routes:
-tgext.routes:
-tgext.routes:
-tgext.routes:
-tgext.routes: