aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--libraries/FreeImage/FreeImage.SlackBuild31
-rw-r--r--libraries/FreeImage/FreeImage.info12
-rw-r--r--libraries/FreeImage/Makefile.fip.DESTDIR.diff41
-rw-r--r--libraries/FreeImage/Makefile.gnu.DESTDIR.diff39
-rw-r--r--libraries/FreeImage/README3
-rw-r--r--libraries/FreeImage/slack-desc4
6 files changed, 25 insertions, 105 deletions
diff --git a/libraries/FreeImage/FreeImage.SlackBuild b/libraries/FreeImage/FreeImage.SlackBuild
index 459d53faf444a..69d36a55594e2 100644
--- a/libraries/FreeImage/FreeImage.SlackBuild
+++ b/libraries/FreeImage/FreeImage.SlackBuild
@@ -2,21 +2,19 @@
# Slackware build script for FreeImage/FreeImagePlus
# Written by Phillip Warner <pc_warner@yahoo.com>
-
-# Modified by Robby Workman <rworkman@slackbuilds.org>
-# with two patches to fix up DESTDIR support :-)
+# Taken over in 2011 by Alan Alberghini <414N@slacky.it
PRGNAM=FreeImage
-VERSION=3.12.0
+VERSION=${VERSION:-3.15.0}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
-# Automatically determine the architecture we're building on:
+DOCS="README.linux license-*.txt Whatsnew.txt Examples/ TestAPI/"
+
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
i?86) ARCH=i486 ;;
arm*) ARCH=arm ;;
- # Unless $ARCH is already set, use uname -m for all other archs:
*) ARCH=$( uname -m ) ;;
esac
fi
@@ -55,22 +53,23 @@ find . \
\( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 \
-o -perm 400 \) -exec chmod 644 {} \;
-patch -p1 < $CWD/Makefile.gnu.DESTDIR.diff
-patch -p1 < $CWD/Makefile.fip.DESTDIR.diff
-
-CFLAGS="$SLKCFLAGS" CXXFLAGS="$SLKCFLAGS" \
-make INSTALLDIR=/usr/lib${LIBDIRSUFFIX} INCDIR=/usr/include
-make install INSTALLDIR=/usr/lib${LIBDIRSUFFIX} INCDIR=/usr/include DESTDIR=$PKG
+CFLAGS="$SLKCFLAGS -fexceptions -fvisibility=hidden -DNO_LCMS" \
+CXXFLAGS="$SLKCFLAGS -fexceptions -fvisibility=hidden -Wno-ctor-dtor-privacy" \
+make INSTALLDIR=$PKG/usr/lib${LIBDIRSUFFIX} DESTDIR=$PKG
+make install INSTALLDIR=$PKG/usr/lib${LIBDIRSUFFIX} DESTDIR=$PKG
-CFLAGS="$SLKCFLAGS" CXXFLAGS="$SLKCFLAGS" \
-make -f Makefile.fip INSTALLDIR=/usr/lib${LIBDIRSUFFIX} INCDIR=/usr/include
-make -f Makefile.fip install INSTALLDIR=/usr/lib${LIBDIRSUFFIX} INCDIR=/usr/include DESTDIR=$PKG
+CFLAGS="$SLKCFLAGS -fexceptions -fvisibility=hidden -DNO_LCMS" \
+CXXFLAGS="$SLKCFLAGS -fexceptions -fvisibility=hidden -Wno-ctor-dtor-privacy" \
+make -f Makefile.fip INSTALLDIR=$PKG/usr/lib${LIBDIRSUFFIX} DESTDIR=$PKG
+make -f Makefile.fip install INSTALLDIR=$PKG/usr/lib${LIBDIRSUFFIX} DESTDIR=$PKG
find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a README.linux license-*.txt Whatsnew.txt Examples/ TestAPI/ $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a \
+ $DOCS \
+ $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
mkdir -p $PKG/install
diff --git a/libraries/FreeImage/FreeImage.info b/libraries/FreeImage/FreeImage.info
index 86c8e1006edd0..fd4e2765ee6bb 100644
--- a/libraries/FreeImage/FreeImage.info
+++ b/libraries/FreeImage/FreeImage.info
@@ -1,10 +1,10 @@
PRGNAM="FreeImage"
-VERSION="3.12.0"
+VERSION="3.15.0"
HOMEPAGE="http://freeimage.sourceforge.net/"
-DOWNLOAD="http://downloads.sourceforge.net/freeimage/FreeImage3120.zip"
-MD5SUM="47b259102f776a4bcd7affc00942f3b4"
+DOWNLOAD="http://downloads.sourceforge.net/freeimage/FreeImage3150.zip"
DOWNLOAD_x86_64=""
+MD5SUM="3b4f08e4985b269beb29a2fced1ef888"
MD5SUM_x86_64=""
-MAINTAINER="Phillip Warner"
-EMAIL="pc_warner@yahoo.com"
-APPROVED="dsomero"
+MAINTAINER="Alan Alberghini"
+EMAIL="414N@slacky.it"
+APPROVED="dsomero,Niels Horn"
diff --git a/libraries/FreeImage/Makefile.fip.DESTDIR.diff b/libraries/FreeImage/Makefile.fip.DESTDIR.diff
deleted file mode 100644
index 4861adf27282b..0000000000000
--- a/libraries/FreeImage/Makefile.fip.DESTDIR.diff
+++ /dev/null
@@ -1,41 +0,0 @@
---- FreeImage/Makefile.fip.orig 2009-09-07 01:09:47.000000000 -0500
-+++ FreeImage/Makefile.fip 2009-09-07 01:27:12.000000000 -0500
-@@ -15,16 +15,11 @@
-
- MODULES = $(SRCS:.c=.o)
- MODULES := $(MODULES:.cpp=.o)
--CFLAGS ?= -O3 -fexceptions -fvisibility=hidden
-+CFLAGS ?= -fexceptions -fvisibility=hidden
- CFLAGS += $(INCLUDE)
--CXXFLAGS ?= -O3 -fexceptions -fvisibility=hidden -Wno-ctor-dtor-privacy
-+CXXFLAGS ?= -fexceptions -fvisibility=hidden -Wno-ctor-dtor-privacy
- CXXFLAGS += $(INCLUDE)
-
--ifeq ($(shell sh -c 'uname -m 2>/dev/null || echo not'),x86_64)
-- CFLAGS += -fPIC
-- CXXFLAGS += -fPIC
--endif
--
- TARGET = freeimageplus
- STATICLIB = lib$(TARGET).a
- SHAREDLIB = lib$(TARGET)-$(VER_MAJOR).$(VER_MINOR).so
-@@ -62,11 +57,14 @@
- $(CC) -shared -Wl,-soname,$(VERLIBNAME) $(LDFLAGS) -o $@ $(MODULES) $(LIBRARIES)
-
- install:
-- install -d $(INCDIR) $(INSTALLDIR)
-- install -m 644 -o root -g root $(HEADER) $(INCDIR)
-- install -m 644 -o root -g root $(HEADERFIP) $(INCDIR)
-- install -m 644 -o root -g root $(STATICLIB) $(INSTALLDIR)
-- install -m 755 -o root -g root $(SHAREDLIB) $(INSTALLDIR)
-+ install -d 755 $(DESTDIR)/$(INCDIR)
-+ install -m 644 $(HEADER) $(DESTDIR)/$(INCDIR)
-+ install -m 644 $(HEADERFIP) $(DESTDIR)/$(INCDIR)
-+ install -d 755 $(DESTDIR)/$(INSTALLDIR)
-+ install -m 644 $(STATICLIB) $(DESTDIR)/$(INSTALLDIR)
-+ install -m 755 $(SHAREDLIB) $(DESTDIR)/$(INSTALLDIR)
-+ cd $(DESTDIR)/$(INSTALLDIR) ; ln -sf $(SHAREDLIB) $(VERLIBNAME)
-+ cd $(DESTDIR)/$(INSTALLDIR) ; ln -sf $(VERLIBNAME) $(LIBNAME)
-
- clean:
- rm -f core Dist/*.* u2dtmp* $(MODULES) $(STATICLIB) $(SHAREDLIB) $(LIBNAME)
diff --git a/libraries/FreeImage/Makefile.gnu.DESTDIR.diff b/libraries/FreeImage/Makefile.gnu.DESTDIR.diff
deleted file mode 100644
index 07d2579cf937e..0000000000000
--- a/libraries/FreeImage/Makefile.gnu.DESTDIR.diff
+++ /dev/null
@@ -1,39 +0,0 @@
---- FreeImage/Makefile.gnu.orig 2009-09-07 01:09:57.000000000 -0500
-+++ FreeImage/Makefile.gnu 2009-09-07 01:27:41.000000000 -0500
-@@ -15,16 +15,11 @@
-
- MODULES = $(SRCS:.c=.o)
- MODULES := $(MODULES:.cpp=.o)
--CFLAGS ?= -O3 -fPIC -fexceptions -fvisibility=hidden
-+CFLAGS ?= -fPIC -fexceptions -fvisibility=hidden
- CFLAGS += $(INCLUDE)
--CXXFLAGS ?= -O3 -fPIC -fexceptions -fvisibility=hidden -Wno-ctor-dtor-privacy
-+CXXFLAGS ?= -fPIC -fexceptions -fvisibility=hidden -Wno-ctor-dtor-privacy
- CXXFLAGS += $(INCLUDE)
-
--ifeq ($(shell sh -c 'uname -m 2>/dev/null || echo not'),x86_64)
-- CFLAGS += -fPIC
-- CXXFLAGS += -fPIC
--endif
--
- TARGET = freeimage
- STATICLIB = lib$(TARGET).a
- SHAREDLIB = lib$(TARGET)-$(VER_MAJOR).$(VER_MINOR).so
-@@ -61,10 +56,13 @@
- $(CC) -shared -Wl,-soname,$(VERLIBNAME) $(LDFLAGS) -o $@ $(MODULES) $(LIBRARIES)
-
- install:
-- install -d $(INCDIR) $(INSTALLDIR)
-- install -m 644 -o root -g root $(HEADER) $(INCDIR)
-- install -m 644 -o root -g root $(STATICLIB) $(INSTALLDIR)
-- install -m 755 -o root -g root $(SHAREDLIB) $(INSTALLDIR)
-+ install -d 755 $(DESTDIR)/$(INCDIR)
-+ install -m 644 $(HEADER) $(DESTDIR)/$(INCDIR)
-+ install -d 755 $(DESTDIR)/$(INSTALLDIR)
-+ install -m 644 $(STATICLIB) $(DESTDIR)/$(INSTALLDIR)
-+ install -m 755 $(SHAREDLIB) $(DESTDIR)/$(INSTALLDIR)
-+ cd $(DESTDIR)/$(INSTALLDIR) ; ln -sf $(SHAREDLIB) $(VERLIBNAME)
-+ cd $(DESTDIR)/$(INSTALLDIR) ; ln -sf $(VERLIBNAME) $(LIBNAME)
-
- clean:
- rm -f core Dist/*.* u2dtmp* $(MODULES) $(STATICLIB) $(SHAREDLIB) $(LIBNAME)
diff --git a/libraries/FreeImage/README b/libraries/FreeImage/README
index 1ff183df5c998..160f7cb416e5c 100644
--- a/libraries/FreeImage/README
+++ b/libraries/FreeImage/README
@@ -4,4 +4,5 @@ FreeImage is an Open Source library project for developers who would like
to support popular graphics image formats like PNG, BMP, JPEG, TIFF and
others as needed by today's multimedia applications. FreeImage is easy to
use, fast, and multithreading safe.
-This script compiles the FreeImage library and the FreeImagePlus C++ wrapper.
+This script compiles the FreeImage library and the FreeImagePlus C++
+wrapper.
diff --git a/libraries/FreeImage/slack-desc b/libraries/FreeImage/slack-desc
index 8829cfff714b7..48bcea844d17c 100644
--- a/libraries/FreeImage/slack-desc
+++ b/libraries/FreeImage/slack-desc
@@ -5,9 +5,9 @@
# exactly 11 lines for the formatting to be correct. It's also customary to
# leave one space after the ':'.
- |-----handy-ruler--------------------------------------------------|
+ |-----handy-ruler------------------------------------------------------|
FreeImage: FreeImage (image library)
-FreeImage:
+FreeImage:
FreeImage: FreeImage is an Open Source library project for developers who
FreeImage: want to support popular graphics image formats like PNG, BMP,
FreeImage: JPEG, TIFF and others needed by today's multimedia applications.