aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--python/pyOpenSSL/README3
-rw-r--r--python/pyOpenSSL/pyOpenSSL.SlackBuild3
2 files changed, 4 insertions, 2 deletions
diff --git a/python/pyOpenSSL/README b/python/pyOpenSSL/README
index 70e1a0d8260a2..dbbca3b70ed55 100644
--- a/python/pyOpenSSL/README
+++ b/python/pyOpenSSL/README
@@ -2,3 +2,6 @@ Python wrapper around a small subset of the OpenSSL library. Includes:
X509 Certificates, SSL Context objects, SSL Connection objects using
Python sockets as transport layer. The Connection object wraps all the
socket methods and can therefore be used in.
+
+This package only build python3 modules.
+If you need python2 modules, please install python2-pyOpenSSL package.
diff --git a/python/pyOpenSSL/pyOpenSSL.SlackBuild b/python/pyOpenSSL/pyOpenSSL.SlackBuild
index 1b411b0962304..6d83a9365a0cb 100644
--- a/python/pyOpenSSL/pyOpenSSL.SlackBuild
+++ b/python/pyOpenSSL/pyOpenSSL.SlackBuild
@@ -31,7 +31,7 @@ cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=pyOpenSSL
VERSION=${VERSION:-22.1.0}
-BUILD=${BUILD:-1}
+BUILD=${BUILD:-2}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -82,7 +82,6 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-python2 setup.py install --root=$PKG
python3 setup.py install --root=$PKG
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \