aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--python/pytest-runner/=1.15.0]0
-rw-r--r--python/pytest-runner/pytest-runner.SlackBuild9
2 files changed, 3 insertions, 6 deletions
diff --git a/python/pytest-runner/=1.15.0] b/python/pytest-runner/=1.15.0]
new file mode 100644
index 0000000000000..e69de29bb2d1d
--- /dev/null
+++ b/python/pytest-runner/=1.15.0]
diff --git a/python/pytest-runner/pytest-runner.SlackBuild b/python/pytest-runner/pytest-runner.SlackBuild
index 3a0a0df1555a8..e9a9a205dd6aa 100644
--- a/python/pytest-runner/pytest-runner.SlackBuild
+++ b/python/pytest-runner/pytest-runner.SlackBuild
@@ -69,12 +69,9 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-python setup.py install --root=$PKG
-
-if $(python3 -c 'import sys' 2>/dev/null); then
- rm -rf build
- python3 setup.py install --root=$PKG
-fi
+python2 setup.py install --root=$PKG
+rm -rf build
+python3 setup.py install --root=$PKG
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true