aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--python/email-validator/email-validator.SlackBuild9
-rw-r--r--python/email-validator/email-validator.info6
2 files changed, 6 insertions, 9 deletions
diff --git a/python/email-validator/email-validator.SlackBuild b/python/email-validator/email-validator.SlackBuild
index 43e2b8384556a..e4bd903c7cedf 100644
--- a/python/email-validator/email-validator.SlackBuild
+++ b/python/email-validator/email-validator.SlackBuild
@@ -26,7 +26,7 @@ cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=email-validator
SRCNAM=$(echo $PRGNAM | sed 's/\-/_/')
-VERSION=${VERSION:-1.3.0}
+VERSION=${VERSION:-1.3.1}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -39,9 +39,6 @@ if [ -z "$ARCH" ]; then
esac
fi
-# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
-# the name of the created package would be, and then exit. This information
-# could be useful to other scripts.
if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
exit 0
@@ -76,9 +73,9 @@ cd $SRCNAM-$VERSION
chown -R root:root .
find -L . \
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
+ -o -perm 511 \) -exec chmod 755 {} \+ -o \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \+
python3 setup.py install --root=$PKG
diff --git a/python/email-validator/email-validator.info b/python/email-validator/email-validator.info
index e92777447c6a9..abc33733a19ce 100644
--- a/python/email-validator/email-validator.info
+++ b/python/email-validator/email-validator.info
@@ -1,8 +1,8 @@
PRGNAM="email-validator"
-VERSION="1.3.0"
+VERSION="1.3.1"
HOMEPAGE="https://github.com/JoshData/python-email-validator"
-DOWNLOAD="https://files.pythonhosted.org/packages/source/e/email-validator/email_validator-1.3.0.tar.gz"
-MD5SUM="846ac7c706dbbf2e78d64c387eb7f869"
+DOWNLOAD="https://files.pythonhosted.org/packages/source/e/email-validator/email_validator-1.3.1.tar.gz"
+MD5SUM="6423b8c6277ec31e7bae2a752718f4de"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES=""