aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--python/python2-suds/README (renamed from python/python-suds/README)0
-rw-r--r--python/python2-suds/python2-suds.SlackBuild (renamed from python/python-suds/python-suds.SlackBuild)13
-rw-r--r--python/python2-suds/python2-suds.info (renamed from python/python-suds/python-suds.info)2
-rw-r--r--python/python2-suds/slack-desc (renamed from python/python-suds/slack-desc)24
4 files changed, 20 insertions, 19 deletions
diff --git a/python/python-suds/README b/python/python2-suds/README
index 7ae900bb0bdd..7ae900bb0bdd 100644
--- a/python/python-suds/README
+++ b/python/python2-suds/README
diff --git a/python/python-suds/python-suds.SlackBuild b/python/python2-suds/python2-suds.SlackBuild
index 8528f26b9473..069a01fb4de8 100644
--- a/python/python-suds/python-suds.SlackBuild
+++ b/python/python2-suds/python2-suds.SlackBuild
@@ -3,14 +3,15 @@
# Slackware build script for python-suds
# Written by Joey Trungale <joey@trungale.net>
-PRGNAM=python-suds
+PRGNAM=python2-suds
+SRCNAM=python-suds
VERSION=${VERSION:-0.3.9}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
- i?86) ARCH=i486 ;;
+ i?86) ARCH=i586 ;;
arm*) ARCH=arm ;;
*) ARCH=$( uname -m ) ;;
esac
@@ -28,9 +29,9 @@ set -e
rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
-rm -rf $PRGNAM-$VERSION
-tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
-cd $PRGNAM-$VERSION
+rm -rf $SRCNAM-$VERSION
+tar xvf $CWD/$SRCNAM-$VERSION.tar.gz
+cd $SRCNAM-$VERSION
chown -R root:root .
find -L . \
@@ -39,7 +40,7 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
-exec chmod 644 {} \;
-python setup.py install --root=$PKG
+python2 setup.py install --root=$PKG
find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
diff --git a/python/python-suds/python-suds.info b/python/python2-suds/python2-suds.info
index 20e55395862d..8655686b7503 100644
--- a/python/python-suds/python-suds.info
+++ b/python/python2-suds/python2-suds.info
@@ -1,4 +1,4 @@
-PRGNAM="python-suds"
+PRGNAM="python2-suds"
VERSION="0.3.9"
HOMEPAGE="https://fedorahosted.org/suds/"
DOWNLOAD="http://ponce.cc/slackware/sources/repo/python-suds-0.3.9.tar.gz"
diff --git a/python/python-suds/slack-desc b/python/python2-suds/slack-desc
index bdae7dc5f359..30bd23503c86 100644
--- a/python/python-suds/slack-desc
+++ b/python/python2-suds/slack-desc
@@ -5,15 +5,15 @@
# You must make exactly 11 lines for the formatting to be correct. It's also
# customary to leave one space after the ':' except on otherwise blank lines.
- |-----handy-ruler------------------------------------------------------|
-python-suds: python-suds (Python SOAP client)
-python-suds:
-python-suds: Suds is a lightweight SOAP python client for consuming Web Services.
-python-suds:
-python-suds: https://fedorahosted.com/suds
-python-suds:
-python-suds:
-python-suds:
-python-suds:
-python-suds:
-python-suds:
+ |-----handy-ruler------------------------------------------------------|
+python2-suds: python2-suds (Python SOAP client)
+python2-suds:
+python2-suds: Suds is a lightweight SOAP python client for consuming Web Services.
+python2-suds:
+python2-suds: https://fedorahosted.com/suds
+python2-suds:
+python2-suds:
+python2-suds:
+python2-suds:
+python2-suds:
+python2-suds: