aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--system/virtualbox-kernel/virtualbox-kernel.SlackBuild10
1 files changed, 8 insertions, 2 deletions
diff --git a/system/virtualbox-kernel/virtualbox-kernel.SlackBuild b/system/virtualbox-kernel/virtualbox-kernel.SlackBuild
index d6c0e8a5843f..d87968680206 100644
--- a/system/virtualbox-kernel/virtualbox-kernel.SlackBuild
+++ b/system/virtualbox-kernel/virtualbox-kernel.SlackBuild
@@ -70,8 +70,14 @@ if ! [ "${HARDENING:-yes}" = "yes" ]; then
{vboxdrv,vboxnetadp,vboxnetflt,vboxpci}/Makefile
fi
-KERNEL_MINOR=$(echo $KERNEL | cut -d "." -f 2)
-KERNEL_PATCH=$(echo $KERNEL | cut -d "." -f 3)
+KERNEL_LOCALVERSION=$(zgrep "CONFIG_LOCALVERSION=" /proc/config.gz | cut -d '"' -f 2)
+if [ -z "$KERNEL_LOCALVERSION" ]; then
+ KERNEL_MINOR=$(echo $KERNEL | cut -d "." -f 2)
+ KERNEL_PATCH=$(echo $KERNEL | cut -d "." -f 3)
+else
+ KERNEL_MINOR=$(echo $KERNEL | sed "s|$KERNEL_LOCALVERSION||" | cut -d "." -f 2)
+ KERNEL_PATCH=$(echo $KERNEL | sed "s|$KERNEL_LOCALVERSION||" | cut -d "." -f 3)
+fi
# Work around API break introduced in kernel 4.4.168
if [ "$KERNEL_MINOR" = 4 -a "$KERNEL_PATCH" -ge 168 ]; then