aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--python/python-spidermonkey/README3
-rw-r--r--python/python-spidermonkey/python-spidermonkey.SlackBuild6
-rw-r--r--python/python-spidermonkey/python-spidermonkey.info6
3 files changed, 10 insertions, 5 deletions
diff --git a/python/python-spidermonkey/README b/python/python-spidermonkey/README
index 7eaa3a104418..f666d9933463 100644
--- a/python/python-spidermonkey/README
+++ b/python/python-spidermonkey/README
@@ -3,3 +3,6 @@ JavaScript implementation. Allows implementation of JavaScript classes,
objects and functions in Python, and evaluation and calling of JavaScript
scripts and functions respectively. Borrows heavily from Claes Jacobssen's
Javascript Perl module, in turn based on Mozilla's 'PerlConnect' Perl binding.
+
+Code is taken from the mozjs185-port branch of
+https://github.com/garywiz/python-spidermonkey
diff --git a/python/python-spidermonkey/python-spidermonkey.SlackBuild b/python/python-spidermonkey/python-spidermonkey.SlackBuild
index d4d7d3851d88..9a8aea116c86 100644
--- a/python/python-spidermonkey/python-spidermonkey.SlackBuild
+++ b/python/python-spidermonkey/python-spidermonkey.SlackBuild
@@ -5,7 +5,7 @@
# Written by Larry Hajali <larryhaja[at]gmail[dot]com>
PRGNAM=python-spidermonkey
-VERSION=${VERSION:-0.0.8}
+VERSION=${VERSION:-20120725_7c9b4d6}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -30,7 +30,7 @@ rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
rm -rf $PRGNAM-$VERSION
-tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+tar xvf $CWD/$PRGNAM-$VERSION.tar.?z*
cd $PRGNAM-$VERSION
chown -R root:root .
find . \
@@ -42,6 +42,8 @@ find . \
# Get rid of ez_setup.
sed -i '/ez_setup/d' setup.py MANIFEST.in
+export CFLAGS="$(pkg-config --cflags mozjs185 mozilla-nspr)"
+export LDFLAGS="$(pkg-config --libs mozjs185 mozilla-nspr)"
python setup.py install --root=$PKG
find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
diff --git a/python/python-spidermonkey/python-spidermonkey.info b/python/python-spidermonkey/python-spidermonkey.info
index cf11196f24cc..76dc79fd3e40 100644
--- a/python/python-spidermonkey/python-spidermonkey.info
+++ b/python/python-spidermonkey/python-spidermonkey.info
@@ -1,8 +1,8 @@
PRGNAM="python-spidermonkey"
-VERSION="0.0.8"
+VERSION="20120725_7c9b4d6"
HOMEPAGE="http://pypi.python.org/pypi/python-spidermonkey"
-DOWNLOAD="http://pypi.python.org/packages/source/p/python-spidermonkey/python-spidermonkey-0.0.8.tar.gz"
-MD5SUM="035ffc4650e2193a09dd4f81bc30fafd"
+DOWNLOAD="http://ponce.cc/slackware/sources/repo/python-spidermonkey-20120725_7c9b4d6.tar.xz"
+MD5SUM="9df778f41228aec873d1644c33b44b47"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES="js nose"