aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--python/python3-kodipydent/python3-kodipydent.SlackBuild8
1 files changed, 6 insertions, 2 deletions
diff --git a/python/python3-kodipydent/python3-kodipydent.SlackBuild b/python/python3-kodipydent/python3-kodipydent.SlackBuild
index a1ed26e922120..38aa1c76c69d2 100644
--- a/python/python3-kodipydent/python3-kodipydent.SlackBuild
+++ b/python/python3-kodipydent/python3-kodipydent.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for python3-kodipydent
-# Copyright 2023 Jeremy Hansen jebrhansen+SBo@gmail.com
+# Copyright 2023-2024 Jeremy Hansen jebrhansen+SBo@gmail.com
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -26,7 +26,7 @@ cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=python3-kodipydent
VERSION=${VERSION:-0.3.1}
SRCNAM=${SRCNAM:-kodipydent}
-BUILD=${BUILD:-1}
+BUILD=${BUILD:-2}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -76,6 +76,10 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+# Fix pip check warning
+# Update dependency name to newer alternate and remove version requirement
+sed -i 's/beekeeper.*/beekeeper-alt/' requirements.txt
+
python3 setup.py install --root=$PKG
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \