aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--development/bless/bless.SlackBuild12
1 files changed, 8 insertions, 4 deletions
diff --git a/development/bless/bless.SlackBuild b/development/bless/bless.SlackBuild
index ecf05ad0c2b9..c239839f47bc 100644
--- a/development/bless/bless.SlackBuild
+++ b/development/bless/bless.SlackBuild
@@ -6,6 +6,9 @@
# Licensed under the WTFPL. See http://www.wtfpl.net/txt/copying/ for details.
+# 20230102 bkw: BUILD=3
+# - get rid of useless junk from doc dir.
+
# 20211210 bkw: BUILD=2
# - add patch from Debian's 0.6.0-7 to fix saving preferences.
# - don't include useless skeleton of bless-manual.omf in package.
@@ -18,7 +21,7 @@ cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=bless
VERSION=${VERSION:-0.6.0}
-BUILD=${BUILD:-2}
+BUILD=${BUILD:-3}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -131,9 +134,10 @@ make
make install DESTDIR=$PKG
# --docdir is ignored.
+PKGDOC=$PKG/usr/doc/$PRGNAM-$VERSION
mkdir -p $PKG/usr/doc/
-mv $PKG/usr/share/doc/$PRGNAM $PKG/usr/doc/$PRGNAM-$VERSION
-rm -rf $PKG/usr/share/doc $PKG/usr/share/omf
+mv $PKG/usr/share/doc/$PRGNAM $PKGDOC
+rm -rf $PKG/usr/share/{doc,omf} $PKGDOC/{INSTALL,README.packaging,bless.spec}
# The help script needed help.
PKGHELP=$PKG/usr/share/$PRGNAM/help_script.sh
@@ -154,7 +158,7 @@ ln -s ../icons/hicolor/48x48/apps/$PRGNAM.png $PIXMAPS/$PRGNAM.png
sed -i '/Icon=/s,=.*,=bless,' $PKG/usr/share/applications/$PRGNAM.desktop
-cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+cat $CWD/$PRGNAM.SlackBuild > $PKGDOC/$PRGNAM.SlackBuild
mkdir -p $PKG/install
cat $CWD/slack-desc > $PKG/install/slack-desc