aboutsummaryrefslogtreecommitdiff
path: root/system
diff options
context:
space:
mode:
authorB. Watson <urchlay@slackware.uk>2024-08-13 19:35:24 -0400
committerWilly Sudiarto Raharjo <willysr@slackbuilds.org>2024-08-17 18:14:20 +0700
commit244a45782d650d891830ad1a6cbff66e07968a66 (patch)
treec165e77db9444dba3f3dbc553c9a8d198c672eb0 /system
parent07eea9e8f5cab2a8008d918367aa846d50119f41 (diff)
system/mount-zip: Updated for version 1.0.15.
Signed-off-by: B. Watson <urchlay@slackware.uk> Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'system')
-rw-r--r--system/mount-zip/mount-zip.SlackBuild24
-rw-r--r--system/mount-zip/mount-zip.info6
-rw-r--r--system/mount-zip/slackware-15.0-libzip.diff21
3 files changed, 9 insertions, 42 deletions
diff --git a/system/mount-zip/mount-zip.SlackBuild b/system/mount-zip/mount-zip.SlackBuild
index 2c4bd5daf38a6..627d1d06268fd 100644
--- a/system/mount-zip/mount-zip.SlackBuild
+++ b/system/mount-zip/mount-zip.SlackBuild
@@ -7,6 +7,11 @@
# Licensed under the WTFPL. See http://www.wtfpl.net/txt/copying/ for details.
+# 20240813 bkw:
+# - update for v1.0.15.
+# - patch for old libzip version no longer applies, but it's also
+# no longer needed; removed.
+
# 20240209 bkw:
# - update for v1.0.12.
# - relicense as WTFPL with permission from Charadon.
@@ -21,7 +26,7 @@
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=mount-zip
-VERSION=${VERSION:-1.0.12}
+VERSION=${VERSION:-1.0.15}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -65,23 +70,6 @@ chown -R root:root .
find -L . -perm /111 -a \! -perm 755 -a -exec chmod 755 {} + -o \
\! -perm /111 -a \! -perm 644 -a -exec chmod 644 {} +
-# 20230829 bkw: Stop mount-zip from requiring a version of libzip
-# greater than 1.8.0. Long explanation:
-
-# mount-zip calls zip_file_is_seekable() to decide whether it should
-# bother to cache the zip file it's working with. This call was added
-# to libzip in its version 1.9.0, and Slackware 15.0 only has 1.8.0.
-
-# It turns out, zip_file_is_seekable() only returns true for zip
-# files that are not compressed (and not encrypted). This means that
-# "stored" zip files are the only ones that don't get cached. This
-# patch causes all zip files to get cached. It won't have much impact
-# because non-compressed zip files are pretty rare anyway.
-
-# This patch should go away when Slackware 15.1 get released.
-
-patch -p1 < $CWD/slackware-15.0-libzip.diff
-
# 20230829 bkw: actually use SLKCFLAGS.
sed -i "/^CXXFLAGS/s,-O2,$SLKCFLAGS," Makefile lib/Makefile
make
diff --git a/system/mount-zip/mount-zip.info b/system/mount-zip/mount-zip.info
index 37404aa301620..5d24639793121 100644
--- a/system/mount-zip/mount-zip.info
+++ b/system/mount-zip/mount-zip.info
@@ -1,8 +1,8 @@
PRGNAM="mount-zip"
-VERSION="1.0.12"
+VERSION="1.0.15"
HOMEPAGE="https://github.com/google/mount-zip"
-DOWNLOAD="https://github.com/google/mount-zip/archive/v1.0.12/mount-zip-1.0.12.tar.gz"
-MD5SUM="f7e2ace30c17737b166c413cee25d49b"
+DOWNLOAD="https://github.com/google/mount-zip/archive/v1.0.15/mount-zip-1.0.15.tar.gz"
+MD5SUM="f85142dceb5481a2eb97367bee264e5f"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES=""
diff --git a/system/mount-zip/slackware-15.0-libzip.diff b/system/mount-zip/slackware-15.0-libzip.diff
deleted file mode 100644
index f3cc7c34b76a7..0000000000000
--- a/system/mount-zip/slackware-15.0-libzip.diff
+++ /dev/null
@@ -1,21 +0,0 @@
-diff -Naur mount-zip-1.0.9/lib/data_node.cc mount-zip-1.0.9.patched/lib/data_node.cc
---- mount-zip-1.0.9/lib/data_node.cc 2023-08-17 01:41:40.000000000 -0400
-+++ mount-zip-1.0.9.patched/lib/data_node.cc 2023-08-29 02:59:18.342998941 -0400
-@@ -269,7 +269,7 @@
- ZipFile file = Reader::Open(zip, id);
- assert(file);
-
-- const bool seekable = zip_file_is_seekable(file.get()) > 0;
-+ const bool seekable = false;
- if (seekable) {
- Log(LOG_DEBUG, "No need to cache ", file_node, ": File is seekable");
- return false;
-@@ -293,7 +293,7 @@
- ZipFile file = Reader::Open(zip, id);
- assert(file);
-
-- const bool seekable = zip_file_is_seekable(file.get()) > 0;
-+ const bool seekable = false;
- Reader::Ptr reader(seekable ? new UnbufferedReader(std::move(file), id, size)
- : new BufferedReader(zip, std::move(file), id,
- size, &cached_reader));