aboutsummaryrefslogtreecommitdiff
path: root/system
diff options
context:
space:
mode:
authorPouria Rezaei <Pouria.rz@outlook.com>2024-06-28 22:40:08 +0330
committerWilly Sudiarto Raharjo <willysr@slackbuilds.org>2024-06-29 07:46:33 +0700
commit0c9d9a3dd5e9f96eb17a13aa85ac22f635c129df (patch)
treee0a41d9b070e14a373860e457e3188d0cf3ca312 /system
parent21df05fe918c16edec274e6b8afeadca00effbff (diff)
system/nix: Updated to 2.11.1.
Signed-off-by: Pouria Rezaei <Pouria.rz@outlook.com> Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'system')
-rw-r--r--system/nix/fix_nix_options.patch (renamed from system/nix/fix_nix_DIR_in_doc_local_mk.patch)31
-rw-r--r--system/nix/nix.SlackBuild14
-rw-r--r--system/nix/nix.info8
3 files changed, 32 insertions, 21 deletions
diff --git a/system/nix/fix_nix_DIR_in_doc_local_mk.patch b/system/nix/fix_nix_options.patch
index 375864b0814c9..d9d1ca3d3cf14 100644
--- a/system/nix/fix_nix_DIR_in_doc_local_mk.patch
+++ b/system/nix/fix_nix_options.patch
@@ -1,11 +1,8 @@
-Subject: Fix build phase depending on installed binary
-Author: Thomas Koch <thomas@koch.ro>
-Bug: https://github.com/NixOS/nix/issues/5781
-Forwarded: https://github.com/NixOS/nix/pull/6015
-
+diff --git a/doc/manual/local.mk b/doc/manual/local.mk
+index 66a8cb7..d2db2b3 100644
--- a/doc/manual/local.mk
+++ b/doc/manual/local.mk
-@@ -20,7 +20,7 @@ dummy-env = env -i \
+@@ -24,7 +24,7 @@ dummy-env = env -i \
NIX_STATE_DIR=/dummy \
NIX_CONFIG='cores = 0'
@@ -14,7 +11,7 @@ Forwarded: https://github.com/NixOS/nix/pull/6015
$(d)/%.1: $(d)/src/command-ref/%.md
@printf "Title: %s\n\n" "$$(basename $@ .1)" > $^.tmp
-@@ -44,31 +44,31 @@ $(d)/src/SUMMARY.md: $(d)/src/SUMMARY.md
+@@ -48,31 +48,31 @@ $(d)/src/SUMMARY.md: $(d)/src/SUMMARY.md.in $(d)/src/command-ref/new-cli
$(trace-gen) cat doc/manual/src/SUMMARY.md.in | while IFS= read line; do if [[ $$line = @manpages@ ]]; then cat doc/manual/src/command-ref/new-cli/SUMMARY.md; else echo "$$line"; fi; done > $@.tmp
@mv $@.tmp $@
@@ -41,11 +38,11 @@ Forwarded: https://github.com/NixOS/nix/pull/6015
+ $(trace-gen) $(dummy-env) $(nix_DIR)/nix show-config --json --experimental-features nix-command > $@.tmp
@mv $@.tmp $@
--$(d)/src/expressions/builtins.md: $(d)/builtins.json $(d)/generate-builtins.nix $(d)/src/expressions/builtins-prefix.md $(bindir)/nix
-+$(d)/src/expressions/builtins.md: $(d)/builtins.json $(d)/generate-builtins.nix $(d)/src/expressions/builtins-prefix.md $(nix_DIR)/nix
- @cat doc/manual/src/expressions/builtins-prefix.md > $@.tmp
+-$(d)/src/language/builtins.md: $(d)/builtins.json $(d)/generate-builtins.nix $(d)/src/language/builtins-prefix.md $(bindir)/nix
++$(d)/src/language/builtins.md: $(d)/builtins.json $(d)/generate-builtins.nix $(d)/src/language/builtins-prefix.md $(nix_DIR)/nix
+ @cat doc/manual/src/language/builtins-prefix.md > $@.tmp
$(trace-gen) $(nix-eval) --expr 'import doc/manual/generate-builtins.nix (builtins.fromJSON (builtins.readFile $<))' >> $@.tmp
- @cat doc/manual/src/expressions/builtins-suffix.md >> $@.tmp
+ @cat doc/manual/src/language/builtins-suffix.md >> $@.tmp
@mv $@.tmp $@
-$(d)/builtins.json: $(bindir)/nix
@@ -55,3 +52,15 @@ Forwarded: https://github.com/NixOS/nix/pull/6015
@mv $@.tmp $@
# Generate the HTML manual.
+diff --git a/doc/manual/local.mk b/doc/manual/local.mk
+index 66a8cb7..abf0d2c 100644
+--- a/doc/manual/local.mk
++++ b/doc/manual/local.mk
+@@ -102,6 +102,6 @@ doc/manual/generated/man1/nix3-manpages: $(d)/src/command-ref/new-cli
+ @touch $@
+
+ $(docdir)/manual/index.html: $(MANUAL_SRCS) $(d)/book.toml $(d)/anchors.jq $(d)/custom.css $(d)/src/SUMMARY.md $(d)/src/command-ref/new-cli $(d)/src/command-ref/conf-file.md $(d)/src/language/builtins.md
+- $(trace-gen) RUST_LOG=warn mdbook build doc/manual -d $(DESTDIR)$(docdir)/manual
++ # $(trace-gen) RUST_LOG=warn mdbook build doc/manual -d $(DESTDIR)$(docdir)/manual
+
+ endif
diff --git a/system/nix/nix.SlackBuild b/system/nix/nix.SlackBuild
index 135693305e142..f3e2e835e4074 100644
--- a/system/nix/nix.SlackBuild
+++ b/system/nix/nix.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for nix
-# Copyright 2019-2022 Pouria Rezaei <Pouria.rz@outlook.com>
+# Copyright 2019-2024 Pouria Rezaei <Pouria.rz@outlook.com>
# Copyright 2015 Pragmatic Cypher <slackbuilds@server.ky>
# All rights reserved.
#
@@ -46,7 +46,7 @@
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=nix
-VERSION=${VERSION:-2.8.1}
+VERSION=${VERSION:-2.11.1}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -97,10 +97,12 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \+
-# 20220325 bkw: patch from Debian, stops nix from installing
-# /usr/bin/nix and its libraries during "make". spamming the real
-# root partition is bad, m'kay?
-patch -p1 < $CWD/fix_nix_DIR_in_doc_local_mk.patch
+# - 20220325 bkw: patch from Debian, stops nix from installing
+# /usr/bin/nix and its libraries during "make". spamming the real
+# root partition is bad, m'kay? (Updated)
+# - The above patch was added thanks to Pragmatic Cypher, along with
+# mdbook patch to make it disabled.
+patch -p1 < $CWD/fix_nix_options.patch
autoreconf -vfim
autoheader
diff --git a/system/nix/nix.info b/system/nix/nix.info
index 2165c124bc90d..2368bbe7cdba1 100644
--- a/system/nix/nix.info
+++ b/system/nix/nix.info
@@ -1,10 +1,10 @@
PRGNAM="nix"
-VERSION="2.8.1"
+VERSION="2.11.1"
HOMEPAGE="http://nixos.org/nix"
-DOWNLOAD="https://github.com/NixOS/nix/archive/2.8.1/nix-2.8.1.tar.gz"
-MD5SUM="b2b6a1756fc6e44fd78cebcb24818843"
+DOWNLOAD="https://github.com/NixOS/nix/archive/2.11.1/nix-2.11.1.tar.gz"
+MD5SUM="b103a11f6c6c4e9a4c8c135a02a7540a"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
-REQUIRES="gtest jq libeditline lowdown libcpuid mdbook nlohmann_json"
+REQUIRES="gtest jq libeditline lowdown libcpuid nlohmann_json"
MAINTAINER="Pouria Rezaei"
EMAIL="Pouria.rz@outlook.com"