aboutsummaryrefslogtreecommitdiff
path: root/system/munin-node
diff options
context:
space:
mode:
authorB. Watson <yalhcru@gmail.com>2022-02-12 14:18:10 -0500
committerWilly Sudiarto Raharjo <willysr@slackbuilds.org>2022-02-13 09:17:51 +0700
commitaf6a2953a080c49cfa9aa7895a9a64bd56d14860 (patch)
tree7bbc643824bb1ba51264f067bbea9da5783ec5e6 /system/munin-node
parent7977103a59a2a49b546ff261d2ae98134d3d5b69 (diff)
system/munin-node: Fix 15.0 build.
Signed-off-by: B. Watson <yalhcru@gmail.com> Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'system/munin-node')
-rw-r--r--system/munin-node/munin-node.SlackBuild25
-rw-r--r--system/munin-node/munin-node.info4
2 files changed, 18 insertions, 11 deletions
diff --git a/system/munin-node/munin-node.SlackBuild b/system/munin-node/munin-node.SlackBuild
index 1b1b8f1baba9..cc634dcefeb0 100644
--- a/system/munin-node/munin-node.SlackBuild
+++ b/system/munin-node/munin-node.SlackBuild
@@ -9,6 +9,13 @@
# glitch@glitchwrks.com
# All rights reserved.
+# 20220212 bkw: Modified by SlackBuilds.org:
+# - fix download URL.
+# - add missing dependencies to REQUIRES.
+# - fix build (PERL5LIB).
+# - add -j1 to make commands, since parallel builds don't work.
+# - install plugins to $PKG, not the real root fs!
+
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=munin-node
@@ -18,9 +25,6 @@ TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
ARCH="noarch"
-# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
-# the name of the created package would be, and then exit. This information
-# could be useful to other scripts.
if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
exit 0
@@ -38,15 +42,15 @@ set -e
rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
-rm -rf $PRGNAM-$VERSION
+rm -rf $ARCHIVE_NAME-$VERSION
tar zxvf $CWD/$ARCHIVE_NAME-$VERSION.tar.gz
cd $ARCHIVE_NAME-$VERSION
chown -R root:root .
find -L . \
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
+ -o -perm 511 \) -exec chmod 755 {} \+ -o \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \+
# Fix a bug in Perldoc extension detection
patch Makefile < $CWD/patches/Makefile.patch
@@ -54,9 +58,12 @@ patch Makefile < $CWD/patches/Makefile.patch
# Patch Makefile.config for Slackware-esque install locations
patch Makefile.config < $CWD/patches/Makefile.config.patch
-make LIBDIR=/usr/lib${LIBDIRSUFFIX}
-make install-common-prime install-node-prime \
- install-plugins-prime LIBDIR=/usr/lib${LIBDIRSUFFIX} DESTDIR=$PKG
+# 20220212 bkw: Note: plugins are in /usr/lib/plugins, regardless of
+# build architecture, because this is noarch.
+export PERL5LIB=.
+make -j1 LIBDIR=/usr/lib
+make -j1 install-common-prime install-node-prime \
+ install-plugins-prime LIBDIR=$PKG/usr/lib DESTDIR=$PKG
find $PKG/usr/man -type f -exec gzip -9 {} \;
for i in $( find $PKG/usr/man -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
diff --git a/system/munin-node/munin-node.info b/system/munin-node/munin-node.info
index bfbd75c9c8cd..7e7b975e5fab 100644
--- a/system/munin-node/munin-node.info
+++ b/system/munin-node/munin-node.info
@@ -1,10 +1,10 @@
PRGNAM="munin-node"
VERSION="2.0.25"
HOMEPAGE="http://munin-monitoring.org"
-DOWNLOAD="http://downloads.munin-monitoring.org/munin/stable/2.0.25/munin-2.0.25.tar.gz"
+DOWNLOAD="http://http.debian.net/debian/pool/main/m/munin/munin_2.0.25.orig.tar.gz"
MD5SUM="b418a667ce42665557329a7ac3bd1b93"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
-REQUIRES="perl-Net-Server perl-Module-Build"
+REQUIRES="perl-Net-Server perl-Module-Build perl-HTML-Template perl-Log-Log4perl openjdk8"
MAINTAINER="Jonathan Chapman"
EMAIL="glitch@glitchwrks.com"