aboutsummaryrefslogtreecommitdiff
path: root/system/mmv
diff options
context:
space:
mode:
authorB. Watson <urchlay@slackware.uk>2022-12-28 04:13:02 -0500
committerWilly Sudiarto Raharjo <willysr@slackbuilds.org>2022-12-31 09:14:51 +0700
commit026b8068745db71d9107ca0a47232577b051e976 (patch)
treeee3205658ef2fcca9e050d113cdf862b3f720364 /system/mmv
parent8fb7da945be1d62a5d47d6d3da1dd373f581b200 (diff)
downloadslackbuilds-026b8068745db71d9107ca0a47232577b051e976.tar.xz
system/mmv: Updated for version 2.3.
Signed-off-by: B. Watson <urchlay@slackware.uk> Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'system/mmv')
-rw-r--r--system/mmv/mmv.SlackBuild69
-rw-r--r--system/mmv/mmv.info10
2 files changed, 41 insertions, 38 deletions
diff --git a/system/mmv/mmv.SlackBuild b/system/mmv/mmv.SlackBuild
index 4f021fef9865..4e429f435962 100644
--- a/system/mmv/mmv.SlackBuild
+++ b/system/mmv/mmv.SlackBuild
@@ -6,21 +6,26 @@
# Licensed under the WTFPL. See http://www.wtfpl.net/txt/copying/ for details.
-# This is ancient software (1.01b was released in 1990), but still
-# useful. We're treating Debian as upstream here, our version number
-# matches their patchlevel (with _ intead of -).
+# 20221228 bkw: update for v2.3.
+
+# This is ancient software (1.01b was released in 1990), but recently
+# someone started maintaining it on github (2.x series), which is
+# excellent! It's now a lot easier to build, and some bugs have been
+# fixed.
+
+# Note to self: do not use the github /archive/ URLs; they require
+# a bunch of cruft and the ./bootstrip script expects to clone git
+# repos. Do use the /releases/download/ URLs; these Just Work with no
+# extra deps.
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=mmv
-VERSION=${VERSION:-1.01b_19}
+VERSION=${VERSION:-2.3}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
-SRCVER="$( echo $VERSION | cut -d_ -f1 )"
-DEBVER="$( echo $VERSION | cut -d_ -f2 )"
-
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
i?86) ARCH=i586 ;;
@@ -57,41 +62,41 @@ set -e
rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
-rm -rf $PRGNAM-$SRCVER.orig
-tar xvf $CWD/${PRGNAM}_$SRCVER.orig.tar.gz
-cd $PRGNAM-$SRCVER.orig
-tar xvf $CWD/${PRGNAM}_$SRCVER-$DEBVER.debian.tar.xz
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+cd $PRGNAM-$VERSION
chown -R root:root .
find -L . -perm /111 -a \! -perm 755 -a -exec chmod 755 {} \+ -o \
\! -perm /111 -a \! -perm 644 -a -exec chmod 644 {} \+
-# apply all Debian's patches:
-for i in $( cat debian/patches/series ); do
- patch -p1 < debian/patches/$i
-done
-
-# one patch of our own:
-patch -p1 < $CWD/compilefix.diff
-
-# the default LDFLAGS cause the build to fail, override with "nothing".
-sed -i "s,-O2,$SLKCFLAGS -Wall," Makefile
-make LDFLAGS=
-
-# easier to do this manually (only 2 files):
-mkdir -p $PKG/usr/bin $PKG/usr/man/man1
-install -s -m0755 $PRGNAM $PKG/usr/bin
-gzip -9c < $PRGNAM.1 > $PKG/usr/man/man1/$PRGNAM.1.gz
+CFLAGS="$SLKCFLAGS" \
+CXXFLAGS="$SLKCFLAGS" \
+./configure \
+ --prefix=/usr \
+ --libdir=/usr/lib${LIBDIRSUFFIX} \
+ --sysconfdir=/etc \
+ --localstatedir=/var \
+ --mandir=/usr/man \
+ --docdir=/usr/doc/$PRGNAM-$VERSION \
+ --build=$ARCH-slackware-linux
+
+make
+make install-strip DESTDIR=$PKG
+gzip -9 $PKG/usr/man/man?/*.*
# multi-named executable, uses its name to decide what action to take.
-LINKS="mcp mad mln"
+# 'make install' creates the symlinks to the binary but not the man page.
+# in 2.3, the "mad" symlink is gone. doubt anyone misses it.
+LINKS="mcp mln"
for i in $LINKS; do
- ln -s $PRGNAM $PKG/usr/bin/$i
ln -s $PRGNAM.1.gz $PKG/usr/man/man1/$i.1.gz
done
-mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a ANNOUNCE READ.ME ARTICLE debian/changelog $PKG/usr/doc/$PRGNAM-$VERSION
-cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+# README.md is already installed in $PKGDOC. NEWS and ChangeLog
+# are both "see git history at <url>", worth keeping one but not both.
+PKGDOC=$PKG/usr/doc/$PRGNAM-$VERSION
+cp -a AUTHORS ChangeLog $PKGDOC
+cat $CWD/$PRGNAM.SlackBuild > $PKGDOC/$PRGNAM.SlackBuild
mkdir -p $PKG/install
cat $CWD/slack-desc > $PKG/install/slack-desc
diff --git a/system/mmv/mmv.info b/system/mmv/mmv.info
index 9e11c28f0f12..32d30176e6ab 100644
--- a/system/mmv/mmv.info
+++ b/system/mmv/mmv.info
@@ -1,10 +1,8 @@
PRGNAM="mmv"
-VERSION="1.01b_19"
-HOMEPAGE="https://packages.debian.org/sid/mmv"
-DOWNLOAD="https://deb.debian.org/debian/pool/main/m/mmv/mmv_1.01b.orig.tar.gz \
- https://deb.debian.org/debian/pool/main/m/mmv/mmv_1.01b-19.debian.tar.xz"
-MD5SUM="1b2135ab2f17bdfa9e08debbb3c46ad8 \
- 5952faa99a610afdbba73d20d68c6d0f"
+VERSION="2.3"
+HOMEPAGE="https://github.com/rrthomas/mmv/"
+DOWNLOAD="https://github.com/rrthomas/mmv/releases/download/v2.3/mmv-2.3.tar.gz"
+MD5SUM="dcf3b89d34aa14f0cfeeca469da215d5"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES=""