aboutsummaryrefslogtreecommitdiff
path: root/system/gnomint/gnomint.SlackBuild
diff options
context:
space:
mode:
authorMatteo Bernardini <ponce@slackbuilds.org>2020-07-22 11:47:52 +0200
committerRobby Workman <rworkman@slackbuilds.org>2021-04-17 23:25:25 -0500
commitb49f59790d1aa16a5b76ab40f9e84c502e34030e (patch)
tree3abd5c062ba8aa8fb4c1fedfd902fa7c3a0b981b /system/gnomint/gnomint.SlackBuild
parentb79cfa33532436436f279a53eec41f437267734b (diff)
system/gnomint: Apply patches from debian.
Signed-off-by: Matteo Bernardini <ponce@slackbuilds.org>
Diffstat (limited to 'system/gnomint/gnomint.SlackBuild')
-rw-r--r--system/gnomint/gnomint.SlackBuild9
1 files changed, 5 insertions, 4 deletions
diff --git a/system/gnomint/gnomint.SlackBuild b/system/gnomint/gnomint.SlackBuild
index 9f043f0c908f8..7a4f44ca82ef4 100644
--- a/system/gnomint/gnomint.SlackBuild
+++ b/system/gnomint/gnomint.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for gnomint
-# Copyright 2012-2016 Matteo Bernardini <ponce@slackbuilds.org>, Pisa, Italy
+# Copyright 2012-2020 Matteo Bernardini <ponce@slackbuilds.org>, Pisa, Italy
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -24,7 +24,7 @@
PRGNAM=gnomint
VERSION=${VERSION:-1.3.0}
-BUILD=${BUILD:-1}
+BUILD=${BUILD:-2}
TAG=${TAG:-_SBo}
if [ -z "$ARCH" ]; then
@@ -71,9 +71,10 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-cp Makefile.in m4/
+# Apply debian patches
+for i in $CWD/patches/* ; do patch -p1 -i $i ; done
-sed -i 's|CFLAGS="-Wall -Werror "|CFLAGS="${CFLAGS:--Wall -Werror}"|' configure.ac configure
+autoreconf -fi
CFLAGS="$SLKCFLAGS" \
CXXFLAGS="$SLKCFLAGS" \