aboutsummaryrefslogtreecommitdiff
path: root/system/dust
diff options
context:
space:
mode:
authorErich Ritz <erich.public@protonmail.com>2023-02-14 14:03:55 -0600
committerWilly Sudiarto Raharjo <willysr@slackbuilds.org>2023-02-18 10:06:37 +0700
commita69f82a0ddafce005e899838a8a8f6a96758e96e (patch)
tree9ca7ef8ac7b071ef15166cdd979c73e72e3fdbd9 /system/dust
parent0a02edda719b7c96d8ee0fa0c414b7f76a555bd4 (diff)
system/dust: Switch dependency to rust16 from rustup.
Signed-off-by: Erich Ritz <erich.public@protonmail.com> Signed-off-by: Andrew Clemons <andrew.clemons@gmail.com> Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'system/dust')
-rw-r--r--system/dust/README8
-rw-r--r--system/dust/dust.SlackBuild15
-rw-r--r--system/dust/dust.info2
3 files changed, 8 insertions, 17 deletions
diff --git a/system/dust/README b/system/dust/README
index d67801ac8c648..8d3a404d63049 100644
--- a/system/dust/README
+++ b/system/dust/README
@@ -6,11 +6,3 @@ Dust will list a slightly-less-than-the-terminal-height number of the
biggest subdirectories or files and will smartly recurse down the tree
to find the larger ones. There is no need for a '-d' flag or a '-h'
flag. The largest subdirectories will be colored.
-
-This project requires at least Rust version 1.60.0. As such, rustup is
-a compile time only dependency. It can be installed manually beforehand
-by running
- rustup toolchain install 1.60.0
-
-NOTE: The directions in rustup's README must be followed so that the
-rust installed by rustup is preferred over the system rust.
diff --git a/system/dust/dust.SlackBuild b/system/dust/dust.SlackBuild
index b8de4ffd67097..eb3f2c301a8b1 100644
--- a/system/dust/dust.SlackBuild
+++ b/system/dust/dust.SlackBuild
@@ -27,7 +27,7 @@ cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=dust
VERSION=${VERSION:-0.8.4}
-BUILD=${BUILD:-1}
+BUILD=${BUILD:-2}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -152,10 +152,12 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-# strip option was stabilized in the 1.59 release, but Slackware 15.0
-# ships with 1.58. The binary is manually stripped later, so this is
-# not needed.
-sed -i "s|^strip = true||" Cargo.toml
+export PATH="/opt/rust16/bin:$PATH"
+if [ -z "$LD_LIBRARY_PATH" ]; then
+ export LD_LIBRARY_PATH="/opt/rust16/lib$LIBDIRSUFFIX"
+else
+ export LD_LIBRARY_PATH="/opt/rust16/lib$LIBDIRSUFFIX:$LD_LIBRARY_PATH"
+fi
CARGO_HOME=.cargo \
CFLAGS="$SLKCFLAGS" \
@@ -166,9 +168,6 @@ mkdir -p $PKG/usr/bin/
find target -name $PRGNAM -exec install -m 755 {} $PKG/usr/bin/$PRGNAM \;
-find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
- | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
-
mkdir -p $PKG/usr/share/bash-completion/completions
mv completions/dust.bash $PKG/usr/share/bash-completion/completions/dust
mkdir -p $PKG/usr/share/zsh/site-functions
diff --git a/system/dust/dust.info b/system/dust/dust.info
index 55184ec966ebe..c59343700a9c9 100644
--- a/system/dust/dust.info
+++ b/system/dust/dust.info
@@ -191,6 +191,6 @@ MD5SUM="7b34a1287bf49d5f7fa4c31fd8909dbc \
8893d419a205b225e4010d7d02a15c6a"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
-REQUIRES="rustup %README%"
+REQUIRES="rust16"
MAINTAINER="Erich Ritz"
EMAIL="erich.public@protonmail.com"