aboutsummaryrefslogtreecommitdiff
path: root/system/dust/dust.SlackBuild
diff options
context:
space:
mode:
authorErich Ritz <erich.public@protonmail.com>2022-08-30 16:49:26 -0500
committerWilly Sudiarto Raharjo <willysr@slackbuilds.org>2022-09-10 15:19:06 +0700
commitbd09d7ee794cd69067c31a96f84271406a7d83ae (patch)
tree37f0091830a132edc6f65a89304167b167372957 /system/dust/dust.SlackBuild
parent9c43c9cbc77972d3b202d7a8e8d9d240fe60daa8 (diff)
system/dust: Updated for version 0.8.2.
Shell completion files were added to the project. Install the bash and zsh completion files to /usr/share, and leave the rest in the doc directory. Additionally install the newly-added sample configuration file in the doc directory. Signed-off-by: Erich Ritz <erich.public@protonmail.com> Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'system/dust/dust.SlackBuild')
-rw-r--r--system/dust/dust.SlackBuild16
1 files changed, 13 insertions, 3 deletions
diff --git a/system/dust/dust.SlackBuild b/system/dust/dust.SlackBuild
index b7b5c9a6cfe92..e8b1bbd3b066c 100644
--- a/system/dust/dust.SlackBuild
+++ b/system/dust/dust.SlackBuild
@@ -26,7 +26,7 @@
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=dust
-VERSION=${VERSION:-0.8.1}
+VERSION=${VERSION:-0.8.2}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -152,6 +152,11 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+# strip option was stabilized in the 1.59 release, but Slackware 15.0
+# ships with 1.58. The binary is manually stripped later, so this is
+# not needed.
+sed -i "s|^strip = true||" Cargo.toml
+
CARGO_HOME=.cargo \
CFLAGS="$SLKCFLAGS" \
CXXFLAGS="$SLKCFLAGS" \
@@ -164,9 +169,14 @@ find target -name $PRGNAM -exec install -m 755 {} $PKG/usr/bin/$PRGNAM \;
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+mkdir -p $PKG/usr/share/bash-completion/completions
+mv completions/dust.bash $PKG/usr/share/bash-completion/completions/dust
+mkdir -p $PKG/usr/share/zsh/site-functions
+mv completions/_dust $PKG/usr/share/zsh/site-functions/
+
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a -r \
- LICENSE README.md \
+cp -a \
+ LICENSE README.md config completions \
$PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild