aboutsummaryrefslogtreecommitdiff
path: root/system/ds4drv/ds4drv.SlackBuild
diff options
context:
space:
mode:
authorIsaac Yu <isaacyu1@isaacyu1.com>2023-02-19 00:41:40 -0800
committerWilly Sudiarto Raharjo <willysr@slackbuilds.org>2023-02-21 08:51:08 +0700
commit7dbdae225ac37d7dd3fe336f900a30c6f3a13242 (patch)
tree040bae26ca40f6ce57a8db1779813a569b5b2eda /system/ds4drv/ds4drv.SlackBuild
parent812b13c5e364412428dbacfdd926c63bceae71f7 (diff)
system/ds4drv: Update for 0.5.1
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'system/ds4drv/ds4drv.SlackBuild')
-rw-r--r--system/ds4drv/ds4drv.SlackBuild7
1 files changed, 2 insertions, 5 deletions
diff --git a/system/ds4drv/ds4drv.SlackBuild b/system/ds4drv/ds4drv.SlackBuild
index f3a1f1bafdbc..028d4efa2d07 100644
--- a/system/ds4drv/ds4drv.SlackBuild
+++ b/system/ds4drv/ds4drv.SlackBuild
@@ -25,7 +25,7 @@
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=ds4drv
-VERSION=${VERSION:-0.5.0}
+VERSION=${VERSION:-0.5.1}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -38,9 +38,6 @@ if [ -z "$ARCH" ]; then
esac
fi
-# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
-# the name of the created package would be, and then exit. This information
-# could be useful to other scripts.
if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
exit 0
@@ -79,7 +76,7 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-python setup.py install --root=$PKG
+python3 setup.py install --root=$PKG
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true