aboutsummaryrefslogtreecommitdiff
path: root/system/bitrot/bitrot.SlackBuild
diff options
context:
space:
mode:
authorLogan Rathbone <poprocks@gmail.com>2023-09-15 00:42:13 -0400
committerWilly Sudiarto Raharjo <willysr@slackbuilds.org>2023-09-17 00:10:19 +0700
commitc0b0862cd78a7391b7a45f7b795165609244da8a (patch)
tree0801c5f300b2eb5cb66054c0e61c53ba51cc45e3 /system/bitrot/bitrot.SlackBuild
parent9728946b080ae02a036631421154038c9b09c8b3 (diff)
system/bitrot: Update for 1.0.1; update DEP; new maint.
Signed-off-by: Andrew Clemons <andrew.clemons@gmail.com> Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'system/bitrot/bitrot.SlackBuild')
-rw-r--r--system/bitrot/bitrot.SlackBuild9
1 files changed, 6 insertions, 3 deletions
diff --git a/system/bitrot/bitrot.SlackBuild b/system/bitrot/bitrot.SlackBuild
index 17c9a3cfd46b3..6ca44898accc4 100644
--- a/system/bitrot/bitrot.SlackBuild
+++ b/system/bitrot/bitrot.SlackBuild
@@ -2,8 +2,8 @@
# Slackware build script for bitrot
+# Copyright © 2023 Logan Rathbone, Province of Ontario, Canada
# Copyright 2022 Brandon Pribula, BC Canada
-
# Copyright 2018 Donald Cooley South Haven, Indiana USA
# All rights reserved.
#
@@ -27,7 +27,7 @@
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=bitrot
-VERSION=${VERSION:-1.0.0}
+VERSION=${VERSION:-1.0.1}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -78,7 +78,10 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-python3 setup.py install --root=$PKG
+export PYTHONPATH=/opt/python3.9/site-packages/
+
+python3 -m build --no-isolation
+python3 -m installer -d "$PKG" dist/*.whl
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true