aboutsummaryrefslogtreecommitdiff
path: root/python
diff options
context:
space:
mode:
authorisaackwy <isaacyu@protonmail.com>2024-08-03 01:37:40 -0700
committerWilly Sudiarto Raharjo <willysr@slackbuilds.org>2024-08-03 17:28:09 +0700
commit6dac9a841ed6bf7de0e153465c0503f73969bcd8 (patch)
tree8451d4e52ab518fb75271ca2f01e5687590f6c9c /python
parent511f5266f57631b6c2e141f8c89a8502a747dbf7 (diff)
python/python-evdev: Removed (renamed to python3-evdev)
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'python')
-rw-r--r--python/python-evdev/README3
-rw-r--r--python/python-evdev/python-evdev.SlackBuild87
-rw-r--r--python/python-evdev/python-evdev.info10
-rw-r--r--python/python-evdev/slack-desc19
4 files changed, 0 insertions, 119 deletions
diff --git a/python/python-evdev/README b/python/python-evdev/README
deleted file mode 100644
index 9a2720d8a0c2c..0000000000000
--- a/python/python-evdev/README
+++ /dev/null
@@ -1,3 +0,0 @@
-python-evdev allows Python programs running in Linux to read and write
-input events. It provides bindings to both the generic input event
-interface (evdev) and the userspace input subsystem (Uinput).
diff --git a/python/python-evdev/python-evdev.SlackBuild b/python/python-evdev/python-evdev.SlackBuild
deleted file mode 100644
index f18028d337bd6..0000000000000
--- a/python/python-evdev/python-evdev.SlackBuild
+++ /dev/null
@@ -1,87 +0,0 @@
-#!/bin/bash
-
-# Slackware build script for python-evdev
-
-# Copyright 2015 Dugan Chen, Canada <thedoogster@gmail.com>
-# Copyright 2020-2023 Isaac Yu <isaacyu@protonmail.com>
-# Copyright 2023-2024 Erich Ritz, Jenks, Oklahoma, USA
-# All rights reserved.
-#
-# Redistribution and use of this script, with or without modification, is
-# permitted provided that the following conditions are met:
-#
-# 1. Redistributions of this script must retain the above copyright
-# notice, this list of conditions and the following disclaimer.
-#
-# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
-# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
-# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
-# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
-# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
-# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
-# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
-# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
-# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
-# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
-
-cd $(dirname $0) ; CWD=$(pwd)
-
-PRGNAM=python-evdev
-VERSION=${VERSION:-1.7.0}
-BUILD=${BUILD:-1}
-TAG=${TAG:-_SBo}
-PKGTYPE=${PKGTYPE:-tgz}
-
-SRCNAM=evdev
-
-if [ -z "$ARCH" ]; then
- case "$( uname -m )" in
- i?86) ARCH=i586 ;;
- arm*) ARCH=arm ;;
- *) ARCH=$( uname -m ) ;;
- esac
-fi
-
-if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
- echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
- exit 0
-fi
-
-TMP=${TMP:-/tmp/SBo}
-PKG=$TMP/package-$PRGNAM
-OUTPUT=${OUTPUT:-/tmp}
-
-set -e
-
-rm -rf $PKG
-mkdir -p $TMP $PKG $OUTPUT
-cd $TMP
-rm -rf $SRCNAM-$VERSION
-tar xvf $CWD/$SRCNAM-$VERSION.tar.gz
-cd $SRCNAM-$VERSION
-chown -R root:root .
-find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-
-# ... but upstream shipped evdev-1.0.0 with 660 permissions everywhere, so:
-find -L . -perm 660 -exec chmod 644 {} \;
-
-PYVER=$(python3 -c 'import sys; print("%d.%d" % sys.version_info[:2])')
-export PYTHONPATH=/opt/python$PYVER/site-packages/
-python3 setup.py install --root=$PKG
-
-find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
- | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
-
-mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a LICENSE README.rst $PKG/usr/doc/$PRGNAM-$VERSION
-cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
-
-mkdir -p $PKG/install
-cat $CWD/slack-desc > $PKG/install/slack-desc
-
-cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/python/python-evdev/python-evdev.info b/python/python-evdev/python-evdev.info
deleted file mode 100644
index 76e1d03ccc416..0000000000000
--- a/python/python-evdev/python-evdev.info
+++ /dev/null
@@ -1,10 +0,0 @@
-PRGNAM="python-evdev"
-VERSION="1.7.0"
-HOMEPAGE="http://python-evdev.readthedocs.org/en/latest/"
-DOWNLOAD="https://files.pythonhosted.org/packages/source/e/evdev/evdev-1.7.0.tar.gz"
-MD5SUM="ef6d242ed75a92f93022b8715c4c8fe5"
-DOWNLOAD_x86_64=""
-MD5SUM_x86_64=""
-REQUIRES="python3-setuptools-opt"
-MAINTAINER="Erich Ritz"
-EMAIL="erich.public@protonmail.com"
diff --git a/python/python-evdev/slack-desc b/python/python-evdev/slack-desc
deleted file mode 100644
index 5a3bdeeb99018..0000000000000
--- a/python/python-evdev/slack-desc
+++ /dev/null
@@ -1,19 +0,0 @@
-# HOW TO EDIT THIS FILE:
-# The "handy ruler" below makes it easier to edit a package description.
-# Line up the first '|' above the ':' following the base package name, and
-# the '|' on the right side marks the last column you can put a character in.
-# You must make exactly 11 lines for the formatting to be correct. It's also
-# customary to leave one space after the ':' except on otherwise blank lines.
-
- |-----handy-ruler------------------------------------------------------|
-python-evdev: python-evdev (Python input event library)
-python-evdev:
-python-evdev: python-evdev allows Python programs running in Linux to read and
-python-evdev: write input events. It provides bindings to both the generic input
-python-evdev: event interface (evdev) and the userspace input subsystem (Uinput).
-python-evdev:
-python-evdev:
-python-evdev:
-python-evdev:
-python-evdev:
-python-evdev: