aboutsummaryrefslogtreecommitdiff
path: root/python
diff options
context:
space:
mode:
authorJeremy Hansen <jebrhansen+github@gmail.com>2023-09-23 16:42:16 -0700
committerWilly Sudiarto Raharjo <willysr@slackbuilds.org>2023-10-07 00:59:30 +0700
commit8585f25467d18498a08d6696c0292956b952927d (patch)
tree88919e69bb9600bd363f4a22b3e87997ab1d1666 /python
parent46488231d05d7ebb81679248c8d5d5d200054306 (diff)
python/python3-kiwisolver: Version bump to 1.4.5
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'python')
-rw-r--r--python/python3-kiwisolver/README3
-rw-r--r--python/python3-kiwisolver/python3-kiwisolver.SlackBuild10
-rw-r--r--python/python3-kiwisolver/python3-kiwisolver.info6
3 files changed, 11 insertions, 8 deletions
diff --git a/python/python3-kiwisolver/README b/python/python3-kiwisolver/README
index 4eb1dfa4f7019..b35df7080dbf2 100644
--- a/python/python3-kiwisolver/README
+++ b/python/python3-kiwisolver/README
@@ -8,6 +8,3 @@ improvement. Memory savings are consistently > 5x.
This is the Python 3 version of kiwisolver and will coexist with SBo's
python2-kiwisolver package.
-
-python3-kiwisolver 1.4.1 is the last possible version for Slackware
-15.0. Newer versions would require a newer python-setuptools.
diff --git a/python/python3-kiwisolver/python3-kiwisolver.SlackBuild b/python/python3-kiwisolver/python3-kiwisolver.SlackBuild
index 77ad3e3543038..a93c817527e90 100644
--- a/python/python3-kiwisolver/python3-kiwisolver.SlackBuild
+++ b/python/python3-kiwisolver/python3-kiwisolver.SlackBuild
@@ -4,6 +4,7 @@
# Copyright 2018 Serban Udrea <s.udrea@gsi.de>
# Copyright 2022-2023 Isaac Yu <isaacyu@protonmail.com>
+# Copyright 2023 Jeremy Hansen <jebrhansen+SBo@gmail.com>
# All rights reserved.
#
# Redistribution and use of this script, with or without modification,
@@ -28,7 +29,7 @@ cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=python3-kiwisolver
SRCNAM=kiwisolver
-VERSION=${VERSION:-1.4.1}
+VERSION=${VERSION:-1.4.5}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -65,7 +66,12 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-python3 setup.py install --root $PKG
+# Use newer, non-stock setuptools due to package requirements
+# Requres python/python3-setuptools-opt build-time dependency
+export PYTHONPATH=/opt/python3.9/site-packages
+
+python3 -m build --wheel --no-isolation
+python3 -m installer --destdir "$PKG" dist/*.whl
find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
diff --git a/python/python3-kiwisolver/python3-kiwisolver.info b/python/python3-kiwisolver/python3-kiwisolver.info
index dad8fc9c89f1a..1fbe365e435db 100644
--- a/python/python3-kiwisolver/python3-kiwisolver.info
+++ b/python/python3-kiwisolver/python3-kiwisolver.info
@@ -1,8 +1,8 @@
PRGNAM="python3-kiwisolver"
-VERSION="1.4.1"
+VERSION="1.4.5"
HOMEPAGE="https://github.com/nucleic/kiwi"
-DOWNLOAD="https://github.com/nucleic/kiwi/releases/download/1.4.1/kiwisolver-1.4.1.tar.gz"
-MD5SUM="a9ad45ee855ad59bb4625a4daa76ad51"
+DOWNLOAD="https://github.com/nucleic/kiwi/releases/download/1.4.5/kiwisolver-1.4.5.tar.gz"
+MD5SUM="20dea6992699d6be8a563995d7fe0309"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES="cppy python3-wheel"