aboutsummaryrefslogtreecommitdiff
path: root/python
diff options
context:
space:
mode:
authorfourtysixandtwo <fourtysixandtwo@sliderr.net>2023-04-10 08:25:11 -0600
committerWilly Sudiarto Raharjo <willysr@slackbuilds.org>2023-04-15 07:15:35 +0700
commite3cc2a81ded22984d338d40cd84e0c890a7f3ea2 (patch)
tree0568ddb4151a250afb6f9a07a510ddb24f046d86 /python
parent2799c127c19a199fe4308f771449749cdc3c0dc2 (diff)
python/python3-guessit: Updated for version 3.7.1.
Signed-off-by: Andrew Clemons <andrew.clemons@gmail.com> Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'python')
-rw-r--r--python/python3-guessit/python3-guessit.SlackBuild11
-rw-r--r--python/python3-guessit/python3-guessit.info6
2 files changed, 7 insertions, 10 deletions
diff --git a/python/python3-guessit/python3-guessit.SlackBuild b/python/python3-guessit/python3-guessit.SlackBuild
index 6f28957272c5..d50adc5e1909 100644
--- a/python/python3-guessit/python3-guessit.SlackBuild
+++ b/python/python3-guessit/python3-guessit.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for python3-guessit
-# Copyright 2022 fourtysixandtwo <fourtysixandtwo@sliderr.net>
+# Copyright 2022-23 fourtysixandtwo <fourtysixandtwo@sliderr.net>
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -26,7 +26,7 @@ cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=python3-guessit
SRCNAM=$(echo $PRGNAM | sed "s/python3-//")
-VERSION=${VERSION:-3.5.0}
+VERSION=${VERSION:-3.7.1}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -39,9 +39,6 @@ if [ -z "$ARCH" ]; then
esac
fi
-# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
-# the name of the created package would be, and then exit. This information
-# could be useful to other scripts.
if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
exit 0
@@ -76,9 +73,9 @@ cd $SRCNAM-$VERSION
chown -R root:root .
find -L . \
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
+ -o -perm 511 \) -exec chmod 755 {} \+ -o \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \+
python3 setup.py install --root=$PKG
diff --git a/python/python3-guessit/python3-guessit.info b/python/python3-guessit/python3-guessit.info
index 43f8113da063..2d933067cf5f 100644
--- a/python/python3-guessit/python3-guessit.info
+++ b/python/python3-guessit/python3-guessit.info
@@ -1,8 +1,8 @@
PRGNAM="python3-guessit"
-VERSION="3.5.0"
+VERSION="3.7.1"
HOMEPAGE="http://guessit.readthedocs.org/"
-DOWNLOAD="https://files.pythonhosted.org/packages/source/g/guessit/guessit-3.5.0.tar.gz"
-MD5SUM="bd7feb0e85185a9d09bb591955c1899f"
+DOWNLOAD="https://files.pythonhosted.org/packages/source/g/guessit/guessit-3.7.1.tar.gz"
+MD5SUM="a083d77d529c14288719306469672015"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES="python3-babelfish python3-rebulk python3-dateutil"