aboutsummaryrefslogtreecommitdiff
path: root/python
diff options
context:
space:
mode:
authorArTourter <artourter@gmail.com>2023-04-09 22:24:41 +0100
committerWilly Sudiarto Raharjo <willysr@slackbuilds.org>2023-04-15 07:15:32 +0700
commitd88d85304786b092d6763f8142a74310388e8141 (patch)
treecc624e0cdf6b7eb97d48e1c5bbb1cd665a31fb23 /python
parent9634f2a876f188f5e1868e46229edab7dd79fb7f (diff)
downloadslackbuilds-d88d85304786b092d6763f8142a74310388e8141.tar.xz
python/python3-nltk: Updated for version 3.8.1.
- move build system to python3-build python3-installed and wheel - add optional runtime dependency in python3-numpy note in README - correct mention of python3-regex (instead of 'regex') in README Signed-off-by: ArTourter <artourter@gmail.com> Signed-off-by: Andrew Clemons <andrew.clemons@gmail.com> Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'python')
-rw-r--r--python/python3-nltk/README15
-rw-r--r--python/python3-nltk/python3-nltk.SlackBuild7
-rw-r--r--python/python3-nltk/python3-nltk.info8
3 files changed, 16 insertions, 14 deletions
diff --git a/python/python3-nltk/README b/python/python3-nltk/README
index 47cc531d796d..23d0f70541b5 100644
--- a/python/python3-nltk/README
+++ b/python/python3-nltk/README
@@ -1,11 +1,12 @@
Open source Python modules, linguistic data and documentation for
research and development in natural language processing, supporting
-dozens of NLP tasks, with distributions for Windows, Mac OSX and
-Linux.
+dozens of NLP tasks, with distributions for Windows, Mac OSX and Linux.
NLTK comes with many corpora, toy grammars, trained models, etc. A
-complete list is posted at: http://nltk.org/nltk_data/. To retrieve
-all the data, use "python3 -m nltk.downloader all". To ensure system
-wideinstallation, you can run the command "python3 -m nltk.downloader
--d /usr/share/nltk_data all" as root. Note that the 'regex' package,
-also available on SBo, is required to run this command.
+complete list is posted at: http://nltk.org/nltk_data/. To retrieve all
+the data, use "python3 -m nltk.downloader all". To ensure system
+wideinstallation, you can run the command "python3 -m nltk.downloader -d
+/usr/share/nltk_data all" as root. Note that the 'python3-regex'
+package, also available on SBo, is required to run this command.
+
+python3-numpy is an optional runtime dependency.
diff --git a/python/python3-nltk/python3-nltk.SlackBuild b/python/python3-nltk/python3-nltk.SlackBuild
index 7b5f69af3c5f..0654412bba40 100644
--- a/python/python3-nltk/python3-nltk.SlackBuild
+++ b/python/python3-nltk/python3-nltk.SlackBuild
@@ -3,7 +3,7 @@
# Slackware build script for python3-nltk.
#
# Copyright 2009-2011 Marco Bonetti <sid77@slackware.it>
-# Copyright 2015-2022 Gregory J. L. Tourte <artourter@gmail.com>
+# Copyright 2015-2023 Gregory J. L. Tourte <artourter@gmail.com>
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -26,7 +26,7 @@
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=python3-nltk
-VERSION=${VERSION:-3.8}
+VERSION=${VERSION:-3.8.1}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -72,7 +72,8 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
-exec chmod 644 {} \;
-python3 setup.py install --root=$PKG
+python3 -m build --no-isolation
+python3 -m installer -d "$PKG" dist/*.whl
find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
diff --git a/python/python3-nltk/python3-nltk.info b/python/python3-nltk/python3-nltk.info
index 3cff5e8efa23..62b7dbd6e8c4 100644
--- a/python/python3-nltk/python3-nltk.info
+++ b/python/python3-nltk/python3-nltk.info
@@ -1,10 +1,10 @@
PRGNAM="python3-nltk"
-VERSION="3.8"
+VERSION="3.8.1"
HOMEPAGE="http://www.nltk.org/"
-DOWNLOAD="https://github.com/nltk/nltk/archive/refs/tags/3.8/nltk-3.8.tar.gz"
-MD5SUM="4f8f5e235e987eeae5c69c6b8009d2f4"
+DOWNLOAD="https://github.com/nltk/nltk/archive/refs/tags/3.8.1/nltk-3.8.1.tar.gz"
+MD5SUM="e8a74c5fd3ac8f789768636f20cba998"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
-REQUIRES="python3-regex"
+REQUIRES="python3-regex python3-build python3-installer wheel"
MAINTAINER="ArTourter"
EMAIL="artourter@gmail.com"