aboutsummaryrefslogtreecommitdiff
path: root/python
diff options
context:
space:
mode:
authorfourtysixandtwo <fourtysixandtwo@sliderr.net>2023-12-21 17:28:17 -0700
committerWilly Sudiarto Raharjo <willysr@slackbuilds.org>2023-12-22 08:00:23 +0700
commita1421e6f114bd68e9287894a1a3955f2229f2458 (patch)
treeddb9ae002db4cd9f76b8078046afd98ad0e38ed2 /python
parentc75be94c9916d52913249f70ba25d46c2fe5b83a (diff)
downloadslackbuilds-a1421e6f114bd68e9287894a1a3955f2229f2458.tar.xz
python/python3-pydantic: Fix version requirement.
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'python')
-rw-r--r--python/python3-pydantic/python3-pydantic.SlackBuild5
1 files changed, 4 insertions, 1 deletions
diff --git a/python/python3-pydantic/python3-pydantic.SlackBuild b/python/python3-pydantic/python3-pydantic.SlackBuild
index a85f3875f15a..b0f0ab978a90 100644
--- a/python/python3-pydantic/python3-pydantic.SlackBuild
+++ b/python/python3-pydantic/python3-pydantic.SlackBuild
@@ -27,7 +27,7 @@ cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=python3-pydantic
SRCNAM=${PRGNAM#python3-*}
VERSION=${VERSION:-2.5.2}
-BUILD=${BUILD:-1}
+BUILD=${BUILD:-2}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -63,6 +63,9 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \+
+# change version requirement
+sed -i 's/2\.14\.5/2.14.6/' pyproject.toml
+
python3 -m build --no-isolation
python3 -m installer -d "$PKG" dist/*.whl